[mythtv-users] XvMC on NVidia with Myth .20 (Anyone getting good HD off a P4 3.2G or less without XVMC?)

Dave dave at optionsdsl.ca
Fri Jan 5 03:59:58 UTC 2007

Im using a Pentium D dual core 805 (it was cheap) without XvMC and it 
works great, One core runs at 70% while the other runs at 16% decoding 
_and_ displaying 1080i, although its a frontend machine only. XvMC isnt 
worth the headache if you can do it without if ya ask me :) My video 
card is a nvidia 5750 PCI-E.  I like the overlay that still exists in 
the 5xxx series cards :)

Nate Crosno wrote:
> I'm having the same issue -- xine works great with xvmc, but Myth does 
> not. I've tried everything I can think of.  This is my last big 
> hurdle.  It stinks that Myth is so finicky with xvmc while xine seems 
> to work easily for most people.  I'm very interested to hear if you 
> have any luck.
> On a slightly different topic, is anyone getting good quality HD 
> playback *without* XVMC on a P4 3.2 Ghz or less?  If so, do you have 
> HT enabled or disabled? (I've tried both). I thought this should have 
> worked. I think my limiting factor is the PCI video card, but that's 
> all my MB has.  I think the on-board video is AGP, but it's only VGA 
> and I need DVI.  If I cannot get XVMC to work in Myth and others 
> report that this processor is capable of HD, my other option is  a new 
> MB and AGP video card and re-use the rest of my hardware. A quick 
> search on newegg shows I can do that for about $90.
> Thanks,
> Nate
> ------------------------------------------------------------------------
> *From:* mythtv-users-bounces at mythtv.org 
> [mailto:mythtv-users-bounces at mythtv.org] *On Behalf Of *Billy Macdonald
> *Sent:* Wednesday, January 03, 2007 11:31 PM
> *To:* mythtv-users at mythtv.org
> *Subject:* [mythtv-users] XvMC on NVidia with Myth .20
> Hello,
>      For Christmas I bought myself my first HD tuner.  It's a USB 
> tuner Hauppauge HVR 950.  I built a separate backend and have 
> successfully configured it and have made a few test OTA recordings.
>      My frontend is a P4 1.6Ghz machine, so I definitely need XvMC for 
> any hope.  I have the binary NVidia drivers, version 9631 installed 
> and am currently running at a 1280x720 resolution.  I've had no luck 
> trying to get XvMC to work in Myth.  I'm thinking next of trying the 
> SVN versions, although I really don't want to mess with my backends.  
> Will I cause problems running the current SVN on the frontend but .20 
> stock on the backends?
>    I just noticed the release-20-fixes in SVN.  I think I'll give that 
> a shot.
> As to what I've tried so far:
> XvMC works in Xine.  If I do an strace of Xine, I see it load the 
> libXvMCW wrapper, read the /etc/X11/XvMCConfig file, and then load the 
> libXvMCNVIDIA_dyanmic.so.1 file.  In Xine I can play my new HD 
> recordings without studder or any other problems, both 1080i or 720p.  
> So I'm fairly confident that the NVidia stuff is setup right.
> ./configure --enable-xvmc
> Set the options to Standard XvMC, tried with various and no 
> deinterlacing options.
> strace shows mythfrontend loading the XvMCW wrapper, but never even 
> attempts to read the XvMCConfig file or load the Nvidia library.  The 
> OSD display is gray so it's using some sort of XvMC, just not NVidia's 
> I don't think.
> ./configure --enable-xvmc --disable-xvmcw
> It shows that it's linking to XvMCNVIDIA in the make output, but when 
> all is said and done, ldd of mythfrontend does not show it linked to 
> the library.  strace fails to show any attempts to load the XvMCNVIDIA 
> library.
> A bunch of other stuff has been tried too, but I had to stop messing 
> around as my wife wanted to actually use the Myth box :)  But I was 
> having fun tinkering.
>   I've tried various changes in nvidia-settings and xorg.conf, but 
> since myth isn't even trying to use the driver, I don't think anything 
> else really matters.
> And thanks for everything to all of you who do so much.  We love the 
> MythTV.
> Billy
> __________________________________________________
> Do You Yahoo!?
> Tired of spam? Yahoo! Mail has the best spam protection around
> http://mail.yahoo.com
> ------------------------------------------------------------------------
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

More information about the mythtv-users mailing list