[mythtv-users] Problems with encrypted channels

R. G. Newbury newbury at mandamus.org
Fri Jan 5 00:31:34 UTC 2007

Rudy Zijlstra wrote:
> Neosat wrote:
>> I have mythtv with satcard and encrypted channel subscription card and 
>> if I tune to a channel that can not get decryped after some seconds I get:
>> After the message I get only one option to return to main menu. It is 
>> very ennoying because if this happens it stack to that channel and it 
>> is very hard to move away to other channel. 
>> Regards
>> Neeesat   
> I can confirm that one. If you look in the backend logs, you will notice 
> that the CAM is giving some messages. Apparently the backend is not 
> handling those messages too well. When the CAM cannot decrypt, the 
> backend should give a message to frontend, and gracefully be ready to 
> change channel. It should not keep trying to decrypt, as that will 
> certainly fail.
> Cheers,
> Rudy
> P.S. I am not a coder, willing to test though.

This question was raised recently and I posted a possible workaround 
method and requested that the OP try it and report. It has not happened 
to me, so I have not tried it.

check out:  www.gossamer-threads.com/lists/mythtv/users/24172

AS to your original problem, it is clear that the backend should fail 
gracefully in this situation.
Get some logs which show the problem and post a bug report on TRAC. From 
the description, it should not be too hard to code a fail-safe.


More information about the mythtv-users mailing list