[mythtv-users] XvMC on NVidia with Myth .20

Billy Macdonald whmac33 at yahoo.com
Thu Jan 4 07:30:43 UTC 2007


     For Christmas I bought myself my first HD tuner.  It's a USB tuner Hauppauge HVR 950.  I built a separate backend and have successfully configured it and have made a few test OTA recordings.

     My frontend is a P4 1.6Ghz machine, so I definitely need XvMC for any hope.  I have the binary NVidia drivers, version 9631 installed and am currently running at a 1280x720 resolution.  I've had no luck trying to get XvMC to work in Myth.  I'm thinking next of trying the SVN versions, although I really don't want to mess with my backends.  Will I cause problems running the current SVN on the frontend but .20 stock on the backends?

   I just noticed the release-20-fixes in SVN.  I think I'll give that a shot.

As to what I've tried so far:
XvMC works in Xine.  If I do an strace of Xine, I see it load the libXvMCW wrapper, read the /etc/X11/XvMCConfig file, and then load the libXvMCNVIDIA_dyanmic.so.1 file.  In Xine I can play my new HD recordings without studder or any other problems, both 1080i or 720p.  So I'm fairly confident that the NVidia stuff is setup right.

./configure --enable-xvmc
Set the options to Standard XvMC, tried with various and no deinterlacing options.
strace shows mythfrontend loading the XvMCW wrapper, but never even attempts to read the XvMCConfig file or load the Nvidia library.  The OSD display is gray so it's using some sort of XvMC, just not NVidia's I don't think.

./configure --enable-xvmc --disable-xvmcw
It shows that it's linking to XvMCNVIDIA in the make output, but when all is said and done, ldd of mythfrontend does not show it linked to the library.  strace fails to show any attempts to load the XvMCNVIDIA library.

A bunch of other stuff has been tried too, but I had to stop messing around as my wife wanted to actually use the Myth box :)  But I was having fun tinkering.
  I've tried various changes in nvidia-settings and xorg.conf, but since myth isn't even trying to use the driver, I don't think anything else really matters.

And thanks for everything to all of you who do so much.  We love the MythTV.


Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20070103/8c8bd60e/attachment.htm 

More information about the mythtv-users mailing list