[mythtv-users] pcHDTV-5500 Help with NTSC ... please

R. G. Newbury newbury at mandamus.org
Mon Jan 1 07:41:08 UTC 2007

Bob Sully wrote:
> Hey all -
> I am STILL having a hard time with this issue. I cannot get it to scan
> NTSC channels in Myth. When I attempt to do so, I see this
> error....apparently it can't open the NTSC tuner. Do I have a device
> driver missing?
> The expert over on the pcHDTV forum believes it's a Myth configuration
> issue.  Have any of you with this card had this problem?
> 2006-12-30 10:54:04.439 New DB connection, total: 3
> 2006-12-30 10:54:04.440 Connected to database 'mythconverg' at host:
> localhost
> 2006-12-30 10:54:04.440 sourceid 1 has lineup type: CableDigital
> 2006-12-30 10:54:04.554 SaveLineupToCache(CA04507:X) -- success
> 2006-12-30 10:54:04.586 Data fetching complete.
> 2006-12-30 10:54:09.451 Channel(0)::Open(): Can't open video device, error
> "No such file or directory"
> Here is the dmesg info:
> Linux video capture interface: v2.00
> cx2388x dvb driver version 0.0.6 loaded
> CORE cx88[0]: subsystem: 7063:5500, board: pcHDTV HD5500 HDTV
> [card=47,autodetected]
> TV tuner 64 at 0x1fe, Radio tuner -1 at 0x1fe
> GSI 18 sharing vector 0xB9 and IRQ 18
> ACPI: PCI Interrupt 0000:00:09.2[A] -> GSI 17 (level, low) -> IRQ 185
> cx88[0]/2: found at 0000:00:09.2, rev: 5, irq: 185, latency: 32, mmio:
> 0xe9000000
> cx88[0]/2: cx2388x based dvb card
> DVB: registering new adapter (cx88[0]).
> DVB: registering frontend 0 (LG Electronics LGDT3303 VSB/QAM Frontend)...
> cx2388x v4l2 driver version 0.0.6 loaded
> cx88[0]/0: found at 0000:00:09.0, rev: 5, irq: 185, latency: 32, mmio:
> 0xe7000000
> tuner 0-0043: chip found @ 0x86 (cx88[0])
> tda9887 0-0043: tda988[5/6/7] found @ 0x43 (tuner)
> tuner 0-0061: chip found @ 0xc2 (cx88[0])
> tuner 0-0061: type set to 64 (LG TDVS-H06xF)
> cx88[0]/0: registered device video0 [v4l2]
> cx88[0]/0: registered device vbi0
> cx2388x blackbird driver version 0.0.6 loaded
> I can scan in the QAM-256 channels on the DVB side.
> This is the ONLY thing keeping me from getting this kick-ass 768GB HD PVR
> system working. Am I going to have to get another tuner card for the NTSC
> channels? I certainly hope not! I have been told by more than one person
> that it shouldn't be this hard to get both tuners on this card working.
> If anyone can clue me in as to what I'm doing wrong, please let me know!
Your ATSC input shows up at /dev/dvb/adapter0 etc.?

Do you have a /dev/video0?...Because that is where the NTSC (analog) 
input shows up. I don't know exactly what shows up in dmesg when both 
drivers are loaded but you need cx88_dvb and cx8800/cx8802.

You may have to fiddle with your modprobe.conf and maybe even blacklist 
both modules, so that modprobe loads them as you want, rather than the 
kernel doing what it wants.

I don't have this board, and have nor tried to do analog reception on my 
HD3000 but success has been reported here..


More information about the mythtv-users mailing list