[mythtv-users] MythArchive: Failed while running ffmpeg

David Kramer david at thekramers.net
Tue Feb 27 02:29:51 UTC 2007

David Kramer wrote:
> Hi.  I just set up MythTV from atrpm son my FC6 box & PVR-350.  It went
> pretty well.  Thousands of times better than when I tried a couple of
> years ago compiling everything from tarballs.
> One problem I'm having that when I try to use MythArchive to burn a
> recording to DVD.  I'm seeing the following error (wrapped for email):
> ----------------------------------------
> ERROR: Failed while running ffmpeg to re-encode video
> Command was ffmpeg -v -i "/data/mythtv/tmp/work/1/newfile.mpg"
> -r ntsc -target dvd -b 4771k -s 720x480 -acodec ac3
> -ab 192 -ac 2 -copyts -aspec 4:3
> "/data/mythtv/tmp/work/1/newfile2.mpg" -map 0:0 -map 0:1
> ----------------------------------------

I'm following up here, because I found the solution.  I tried running
the command from the command line myself, and saw the following error:

ffmpeg: symbol lookup error: /usr/lib/libavcodec.so.51: undefined
symbol: dlclose

A little googling turned up this thread:

Short version: One of the libraries ffmpeg uses was installed from
livna, and was compiled differently than the one at atrpms.
Incompatible repositories suck.  Swapped it for the one in atrpms and
everything worked great.

More information about the mythtv-users mailing list