[mythtv-users] Plugin UI Menus and objects not installing with make install

Tom Gutwin tgutwin at webarts.bc.ca
Sun Feb 25 23:36:35 UTC 2007

I wanted to put this out there... since I solved this.
Calling the plugins make install from the root mythplugins dir did not install the uifiles

I built mythtv and mythplugins from svn and after getting all the build requirements in
order, make and make install went without errors for both mythtv and mythplugins.
When I went to test out the install, I was finding many of the additional plugins where
giving me an error dialog in mythtv when I went into the plugin menu.

with mythzoneminder It was a popup dialog something like
Could not locate 'status_text' in theme ''

there were other plugin menu errors and hangs.
mythweather would actually crash and stop mythtv.

I ending up tracking it down to the fact that the ui menu files and icons for the plugins
were not getting installed????

I Tried remaking and making the makefile manually with
qmake PREFIX=/usr mythplugins.pro
I am building the following plugins:
mythweather, mythnews, mythgallery, mythweb, mythzoneminder.

still no go when I ran make install (as root) from the root of the mythplugins dir.
So after I built the plugins, I had to call the individual install targets explicitly.
_This worked_

  [root at dvr mythplugins]$ cd mythzoneminder/mythzoneminder
  [root at dvr mythzoneminder]$ make install_target install_menufiles install_uifiles
  [root at dvr mythzoneminder]$ cd ../../mythnews/mythnews
  [root at dvr mythnews]$ make install_target  install_uifiles install_installimages
  [root at dvr mythnews]$ cd ../../mythgallery/mythgallery
  [root at dvr mythgallery]$ make install_target install_installimages install_uifiles
  [root at dvr mythgallery]$ cd ../../mythmusic/mythmusic
  [root at dvr mythmusic]$ make install_target install_installfiles install_uifiles
  [root at dvr mythmusic]$ cd ../../mythweather/mythweather
  [root at dvr mythweather]$ make install_target install_installfiles install_installimages
  [root at dvr mythweather]$ cd ../..

My system is as follows...
FC6 fresh install and updated
this box is also running ZoneMinder
GNU Make 3.81
Myth svn revision 12832

If anyone else has this problem, I hope this helps.

---------------------     WebARTS Design      ---------------------
Tom Gutwin                                          +1-604-626-9242
tgutwin at webarts.bc.ca                      http://www.webarts.bc.ca
GPG/pgp Pub Key: http://www.webarts.bc.ca/docs/tbgGPGPubKey.gpg.asc
---------     Engineering Your Computer Solutions...      ---------

                Try our Free Ogg Vorbis Player

More information about the mythtv-users mailing list