[mythtv-users] transcoding perfect dvd rips to xvid

Mike Schiller mdschiller.mythtv at gmail.com
Thu Feb 22 05:28:38 UTC 2007

Using autoaspect produced properly formatted video.  I still had the
duplicate frame errror, but I'll see if I can redirect stderr so that
it's not so annoying.  The file size (for a ~2hr15m movie) dropped
from 7.3GB down to 1.2GB.

The video quality was very good.  I can see a difference, but it's not
as big as what I expected.  I hadn't planned on converting my action
movies, but now I think that there will only be a few that I don't

The only glitch, is that the audio is playing in Spanish instead of
English.  I ripped the starting file from DVD using mythtv, and
choosing the English audio track, and selecting AC3 audio.  When I
initially tried to play the .vob (and several others that I've ripped
in the past and played in Xine on a Myth 0.19 system) with Myth's
built-in video player, it played the audio in Spanish.  So, I
configured Myth (0.20) to use Xine for playing .vob files, and I got
English as expected.  This means that the .vob file must contain both
English and Spanish, which was not what I expected.

Does anyone have any idea what's going on here?  Is there a way to
tell if the .avi produced contains multiple languages, or to strip out
the Spanish?  If the .avi does have English, how do I configure either
the built-in player or Xine to properly choose the audio track for
both .vob and .avi?

Thanks in advance,

More information about the mythtv-users mailing list