[mythtv-users] channel not being added by mythfilldatabase?

Michael T. Dean mtdean at thirdcontact.com
Tue Feb 20 03:42:39 UTC 2007

On 02/19/2007 08:54 PM, matt lutz wrote:
>  I'm having an odd problem with my one of my lineups (OTA via zap2it).
>  Every time I select a certain channel, the next time I run
>  mythfilldatabse the channel get de-selected in zap2it.  I've posted a
>  message on the zap2it forums, but it has gone unanswered.  Does
>  anyone know what could be happening?  As I said, it's an OTA channel
>  from Washington DC, 5-1 (WTTGDT).
>  I've deleted the lineup & re-added it, but the same thing happens.
>  Here's the relevant output from mythfilldatabase:
>  2007-02-19 20:44:21.755 Grab complete.  Actual data from Tue Feb 20
>  05:00:00 2007 to Wed Feb 21 05:00:00 2007 (UTC)
>  2007-02-19 20:44:21.756 Main temp tables populated.
>  2007-02-19 20:44:21.756 Updating myth channels.
>  2007-02-19 20:44:21.796 DataDirect: Not adding channel WTTGDT
>  Is there any debugging I can put on to figure out why the channel
>  isn't being added?

mythfilldatabase does not add channels to digital lineups unless you 
tell it to do so explicitly with the --only-update-channels 
(non-destructive) option or the --do-channel-updates (destructive) 
option.  Automatically adding to a digital lineup is dangerous as the 
channel may be encrypted or may require additional setup (i.e. scanning) 
to be usable.

See "mythfilldatabase --help".


More information about the mythtv-users mailing list