[mythtv-users] why does my digital-out work with nvidia ck804?

Seth Daniel mythtv.org at sethdaniel.org
Fri Feb 16 20:11:54 UTC 2007


I spent around 2 hours last night playing with my new motherboard with
built-in soundcard.  The motherboard is a Gigabyte GA-M55SLI-S4 and the
sound is an Nvidia CK804 (apparently with the Realtek ALC850 in there
somewhere too). 

Now, as best I can tell, my digital out works just fine (at least when I
played a DVD it worked).  But it doesn't seem to work the way I would
expect it to work.  

There is quite a lot of information out there about this sound setup.
On the mythtv site there is this:

I was mostly following some instructions I found on the alsa site:

If I cat /proc/asound/pcm:

  00-02: Intel ICH - IEC958 : NVidia CK804 - IEC958 : playback 1
  00-01: Intel ICH - MIC ADC : NVidia CK804 - MIC ADC : capture 1
  00-00: Intel ICH : NVidia CK804 : playback 1 : capture 1

This suggests to me that the output device I would want to use would be
0,2.  However the above link says to use 0,0.  Okay.  Why?  This seems
to contradict everything else I have read.

I downloaded some test dolby digital .wav files that were referenced
from somewhere on the mythtv wiki.  I attempted to play them using the

  mplayer -ao alsa:device=hw=0.0 -ac hwac3 file.wav

mplayer died saying that it couldn't find the codec for file type 0x1.
(??)  I still don't know why this was happening even though I spent
close to two hours trying to get it to work.

I also tried:
  mplayer -ao alsa:device=hw=0.0 file.wav
  mplayer -ao alsa:device=hw=0.2 file.wav

The former just spits out a lot of noise as you might expect.  The
latter does nothing.  No sound whatsoever.


  mplayer -ao alsa:device=digital file.wav
  mplayer -ao alsa:device=hw=digital file.wav

I wasn't sure of the proper syntax, but neither of these produce any
sound.  I suspect it's because the digital alias maps to device 0,2
which, as shown earlier, produces no sound.

So I was about to give up when I found a gentoo webpage:

This suggested playing a DVD through mplayer.  So I did this:

  mplayer dvd:// -ao alsa:device=hw=0.0 -ac hwac3 -aid 128

And whaddayouknow it worked.  The Dolby Digital light came on on my
receiver and I verified I was getting discrete sound through my 5.1

So I post this as a potential help to those that might be struggling
with this card.  However, I also post to ask: 
  1) Why do I need to use device 0,0?  
  2) Why doesn't 0,2 work as it seems that is the device for digital out?  
  3) Due to the above I can't use the digital or spdif alias.  Which just
     strikes me as really bizarre. 
  4) Also, does anyone know why I can't play those Dolby Digital wav
     files using mplayer and the hwac3 audio codec?    

Perhaps I should just be glad that sound works, but I would like to
understand why this configuration works the way it does so that I can
debug any problems on down the road.

This was all on Ubuntu Edgy with kernel 2.6.17.  I have an optical cable
from the SPDIF out on my soundcard to the optical-in on my off-board DD
decoder.  I believe it is Alsa 1.0.10.

I also tested playing some ogg files.  They work just fine through
device 0,0.

I have no .asoundrc or any global alsa configuration file.

Thank you to anyone who bothers to read this. :o) 

seth / @sethdaniel.org
Skill without imagination is craftsmanship and gives us many useful objects
such as wickerwork picnic baskets. Imagination without skill gives us modern

More information about the mythtv-users mailing list