[mythtv-users] Can't schedule recordings [SOLVED]

R. G. Newbury newbury at mandamus.org
Thu Feb 15 04:46:08 UTC 2007


Dave M G wrote:
> MythTV Users,
> 
> In another thread I mentioned that I solved a database error to do with 
> collation settings.
> 
> Basically, I had changed the collation on all the tables in the database 
> that seemed to be related to storing data about programs. I changed them 
> to utf-8. This was so I could get proper Japanese character display in 
> the program guide.
> 
> It seemed I had not caught all the relevant tables (I didn't change 
> every single table because there are a lot, and it's a tedious task to 
> do manually). The mismatch was causing some query errors.
> 
> I caught the errors, and converted more tables to use utf-8 collation.
> 
> I happened to notice after this that I could set programs to record in 
> the programme guide!
> 
> I guess the query error was causing a hold up somewhere in the process 
> of setting recordings.
> 
> Bottom line: make sure all the collation settings are consistent.
> 
> 

Maybe you could list the fields and the tables which you had to correct, 
and put the list into the wiki. Since a database error of this sort is 
obscure to start with, and its having caused the 'fail to record' error 
is even more weird (or weirder more).

Geoff


More information about the mythtv-users mailing list