[mythtv-users] building from source for NVIDIA xvmc

Brandon Rogers blrogers at ieee.org
Wed Feb 14 12:52:05 UTC 2007


Yan,

If you run mythfrontend (and start watching TV) from a terminal, does the
output mention that you have successfully started using XvMC or failed?  In
my experience, you need to add a config file /usr/X11R6/lib/X11/XvMCConfig
which contains the location of your nvidia .so
(/usr/X11R6/lib/libXvMCNVIDIA_dynamic.so.1 in my case).  The locations might
be different, but the output from the terminal will tell you exactly where
the config file should be located.  

Also, if your OSD is full color, that is probably an indication that you
aren't using Nvidia XvMC.

Thanks,
Brandon

-----Original Message-----
From: mythtv-users-bounces at mythtv.org
[mailto:mythtv-users-bounces at mythtv.org] On Behalf Of Yan Seiner
Sent: Tuesday, February 13, 2007 11:59 AM
To: Discussion about mythtv
Subject: [mythtv-users] building from source for NVIDIA xvmc

Is there some magic incantation I have to do to build 0.20-fixes for 
nVidia XvMC  support?

When I run ./configure  --enable-xvmc the configure script tells me I am 
using libXvMC....  ISTR that once I got it to say libXvMCNVIDIA but I 
can't swear to that.

I do know that enabling / disabling xvmc makes no difference to my 
choppy playback, so I figure I would start back with building myth, and 
make sure I am doing all the right things.

Should I build against nVidia's libXvMCNVIDIA or the generic libXvMC?  
And if I should use nVidia's lib, how do I tell myth to build against it?

--Yan

_______________________________________________
mythtv-users mailing list
mythtv-users at mythtv.org
http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users



More information about the mythtv-users mailing list