[mythtv-users] Firewire hard locks

Chris Weiland hobbiticus at gmail.com
Tue Feb 13 19:40:08 UTC 2007

I've posted about this before, but never got any good responses, and now
I've had some more time to mess around with it, and this problem now very
high on my priorities to fix.

Recording through firewire works great with my SB audigy 2 zs and my SA3250
HD cable box.  That is until my entire system completely locks up.  None of
the magic key combinations respond, mouse doesn't respond, and
num/scroll/caps log LEDs are frozen.  I can't connect through mythweb or
telnet either (ssh is blocked).  The entire system freezes.  This happens
when watching live TV or while just recording a show through the firewire
port.  I have not been recording anything through my other capture card.

After the computer has been in this state for a few hours, my CPU fan is
spinning very infrequently, which is perfectly normal given my fan speed
control bios settings and CPU frequency scaling.  So, this means that the
CPU is not running at the max clock speed because the CPU is still intact
and the fan is doing little cooling.  And it also means that the CPU is not
doing much work, like getting stuck in some kind of infinite loop, or else
it would be running hotter and the fan would be on continuously.

The problem seems to be "tiggered" sometime after recording starts, but
doesn't actually freeze up the system until recording stops.  For example,
when watching live TV, suddenly the audio will turn into a high pitched
whine, and when I stop watching (press escape), change channel, or kill the
frontend or backend process, the computer will freeze up.  After rebooting
and watching the recording, there is no apparent sign of the problem in the
recording - no audio problems, studders, or other video or audio
corruption.  I have not been able to watch a regular old recording when this
problem occurs because I recently changed my recordings drive to XFS, which
apparently zero's out open file handles when there is a system interruption.

This is what I've got:
Asus M2N-E mobo (nForce 570 chipset) w/ AMD64 3800+ (single core)
SB Audigy 2 ZS, using the firewire port
nVidia 7600 GT PCI-E
pcHDTV 5500 capture card
Kernel version 2.6.20, 32 bit, preempt
Debian Etch (testing), with mythtv packages from
www.debian-multimedia.org(built from svn snapshot from mid january)

I've tried turning on/off the APIC and moving the sound card, capture card,
and ethernet card to different PCI slots.  I'm not sure what to do next.
I've also tried configuring the box as sa3250 and sa4200, as well as
configuring the firewire link speed as 100 and 400 mbps.

Because of the audio corruption while watching live TV, I'm inclined to
believe that it has something to do with my audio setup, but I've never had
any trouble with it before.  I'm running ALSA, and possibly an arts server
for kde (which I don't think is necessary with alsa - if anyone knows,
please say something).  I also build my own kernel and try to compile all
drivers I can into it rather than loading everything as modules (again, if
this is dumb, let me know).  With the exception of alsa and one or two of
the firewire drivers, everything is compiled in.

I also don't know much about troubleshooting lockups like this.  If there
are any logs I should pay attention to, let me know.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20070213/b08227bf/attachment.htm 

More information about the mythtv-users mailing list