[mythtv-users] Network Shares

Richard Conway ric at weirdness.com
Tue Feb 13 15:31:55 UTC 2007

Jeff Wormsley wrote:
> Darren wrote:
>> It will mostly likely be samba denying permission. The samba config file is 
>> usually /etc/samba/smb.conf check it for write access to your share and then 
>> it will only allow access to the user that is logged in. You can cut a corner 
>> and allow global access with a security setting of share.
>> In the [global] section of smb.conf put in or change   security = share   this 
>> is the least secure of settings but will help pin down your problem. A last 
>> word, samba has it's own security file,  you can use    smbpasswd -a username   
>> to add a user with no password, the option -a can only be used by root.
> In case you didn't notice, he's using Windows 2003 servers, not Linux 
> servers, for his Samba shares.
> I too have almost exactly the same problem, only I -do- use a Linux (FC3 
> I believe) Samba server.  Any Windows machine, and my main machine back 
> when it was FC4 could access those shares without any problems, read 
> write, with no password (I am firewalled to the outside world, so I am 
> not worried too much about not using passwords).  When I moved my combo 
> BE/FE from FC4 to FC6, I could no longer automatically mount those 
> shares as read/write.  I tried switching from fstab to automount, and 
> half a dozen other things, even adding the mount command to rc.local (if 
> memory serves), but all I could do was get them to mount read only.  I 
> had to do it by hand to get read/write.  It must be something in FC6.
> Since my files server is Linux, I "solved" my problem by also exporting 
> the same shares with NFS.  With NFS, the mounts in fstab work for 
> read/write.  Thus I access the same shares with NFS for Linux clients 
> and Samba for Windows clients.  That probably won't help the original 
> poster, though.
It could do - its quite possible to create NFS shares on Windows Server 2003

More information about the mythtv-users mailing list