[mythtv-users] moving database from FC4 to gentoo (mysql 4 to 5)

Brad Fuller bradallenfuller at yahoo.com
Sun Feb 11 23:47:07 UTC 2007



David Campbell wrote:
> Brad Fuller wrote:
>   
>> David Campbell wrote:
>>     
>>> Brad Fuller wrote:
>>>   
>>>       
>>>> Thanks David, that worked!
>>>> However, if I go to mythtvsetup, none of the cards are setup. I've setup 
>>>> several MythTVs, but never moved a database (always did it from scratch) 
>>>> so this is new to me.
>>>>
>>>> I would have figured that mythtv-setup would have all the cards, 
>>>> channels, etc filled in. I see that I have channel data, but no card or 
>>>> input source data. Why would this be?
>>>>     
>>>>         
>>> Could it because the hostname of the server has changed?
>>>   
>>>       
>> Yep, now it almost works. User "root" works ok, but when I'm in user 
>> "mythtv" I get a constant barrage of error messages that the host 
>> (called 'killtivo') is not allowed to connect to the MySql server. I 
>> looked in /etc/mysql/my.conf but I don't see anything out of the 
>> ordinary. Probably need to add "killtivo" to some file somewhere!
>>     
>
> Not quite.
>
> in mysql
>
> mysql>grant all on *.mythconverg to mythtv at localhost identified by 
> 'somepassword';
>
> somepassword will be the value in mysql.txt
>   

right, that is actually:

mysql>grant all PRIVILEGES on *.* to mythtv@'killtivo' identified by 'somepassword';

* I added "privileges
* *.mythconverg didn't work. I think it's actually, mythconverg.* isn't it? 
  I made it *.* because I don't care




More information about the mythtv-users mailing list