[mythtv-users] Setting up a USB IR receiver (Streamzap)

Chris Weiland hobbiticus at gmail.com
Sat Feb 10 19:59:31 UTC 2007

I do see the messages in dmesg when I plug/unplug the device.

I do not know where the HID input layer support is in the kernel config.  I
just tried looking for it and didn't see it.  Can you be more specific?

Also, upon further research, it looks like I need to make the streamzap lirc
module and then a dev/lircX device should show up.  However I'm having lots
of trouble with this.  The lirc-modules-source package is supposed to have
this module, but it doesn't compile.  However, I was able to fix the
compilation errors, but all it seems to do in the end is install some .o
files in /lib/modules/usr/src/linux-2.6.20/misc (lirc_dev.o, lirc_gpio.o,
lirc_i2c.o, lirc_streamzap.o).  I don't know what these files are supposed
to do, and their location is very odd.

So, I'm going to try removing the lirc binary package and build it myself.

I built and installed it, and now I have /dev/lirc, /dev/lircd, and
/dev/lircm.  However, /dev/lirc does not seem to be a valid device:
# ls -l /dev/lirc*
crw-r--r-- 1 root root 61, 0 2007-02-10 14:50 /dev/lirc
prw-r--r-- 1 root root     0 2007-02-10 14:50 /dev/lircd
prw-r--r-- 1 root root     0 2007-02-10 14:50 /dev/lircm
# cat /dev/lirc
cat: /dev/lirc: No such device or address

There are no new devices in /dev/usb or /dev/input or /dev/hiddev*

Hopefully I'm getting closer...

On 2/10/07, Brian Wood <beww at beww.org> wrote:
> On Feb 10, 2007, at 12:31 PM, Neil Cherry wrote:
> > Chris Weiland wrote:
> >> This isn't really a mythtv specific question, but I don't know of
> >> many
> >> other places to look.  I just got a Streamzap USB IR receiver, and I
> >> can't seem to figure out how to use it.
> >>
> >> My problem is that I can't get a /dev entry for it.  I think there's
> >> supposed to be a /dev/usb/hiddev0 that is used to interface with the
> >> device, but that file is not there, and I can't figure out how to
> >> get it
> >> there.  Everywhere I've searched says that I just need to enable the
> >> "/dev/hiddevX support" kernel option and then everything will work.
> >> Well, after doing that, the device still doesn't show up anywhere in
> >> /dev.  I can see the device being detected in dmesg whenever I
> >> remove or
> >> plug in the device.  The device shows up in /proc/bus/usb/devices,
> >> lsusb, and usbview, but usbview shows it in red, which, according
> >> to one
> >> site, means that there is "no driver bound to it".  How would I
> >> fix this?
> >>
> >> I think I've also read somewhere that I should be using "hotplug",
> >> which
> >> I guess refers to the hotplug package.  However, if I try to
> >> install it,
> >> apt forces me to remove udev.  Do I want to do this?
> >>
> >> I'm running Debian Etch, kernel 2.6.20.
> >
> > Don't remove udev but remove the usb device, do a dmesg, make a
> > general note of the last few lines, plug in the usb device and
> > do another dmesg. Did you see the new lines? One of them may
> > be an assignment for the device driver. Also if the hid is a kernel
> > module check to see that it's loaded (lsmod) you should see an
> > hid entry (and maybe another hid... something). Sorry I can't
> > remember more at this moment.
> >
> Not specific to Debian but with Gentoo (and I assume all kernels) you
> need to make sure "HID Input Layer support as well as /dev/hiddev raw
> HID input device support are both enabled in the kernel.
> Having the first and not the second will result in precisely the
> behavior you describe, though there are of course other things that
> might cause it as well.
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20070210/a6f44be8/attachment.htm 

More information about the mythtv-users mailing list