[mythtv-users] "Transcode failed with status: 235"...the new "PC LOAD LETTER"

Scott Alfter mythtv at salfter.dyndns.org
Sun Feb 4 00:26:37 UTC 2007

...as in "WTF does that mean?" :-)

Someone else asked this a few months ago, but nobody answered.  It popped up 
for me when I wanted to edit the commercials out of this week's Battlestar 
Galactica for archiving.  The source file was an MPEG-2 transport stream 
recorded from an SA3250HD.  It's 528x480, with an average video bitrate of 
about 3.25 Mbps and 2-channel AC3 audio at 256 kbps.

avidemux2 had no problem loading and cutting this file, so I now have an edited 
MPEG-2 program stream.  (This stream will then get fed to a script that will 
transcode the video to H.264 and the audio to AAC, with the result dumped into 
an MPEG-4 container, but that's neither here nor there.)

After having done the edit with avidemux2, I saw that there was a temporary 
file left behind by the MythTV transcoder.  It was about the same size as the 
avidemux2 output.  When I played it, it appeared to have converted the whole 
file properly, so the only thing that would've been left would be to copy the 
edited file over the original and rebuild the seektable.  Why, then, is it not 
doing that for some files?

I'm running build 12376, as Gentoo builds it.  I've only had this version 
installed for a few days, but I've occasionally seen the same error with 
earlier versions.  Most files transcode OK, but "status 235" isn't particularly 
informative as to what causes some files to not transcode.

(I had some minor database corruption, most likely as a result of a lockup 
earlier this week.  I fixed it with mysqlrepair, but that didn't get the 
transcoder working.)

  / v \ Scott Alfter
(IIGS( http://alfter.us/            Top-posting!
  \_^_/ rm -rf /bin/laden            >What's the most annoying thing on Usenet?

More information about the mythtv-users mailing list