[mythtv-users] New install and my problmes.

Stroller linux.luser at myrealbox.com
Sat Feb 3 16:21:49 UTC 2007

On 2 Feb 2007, at 20:48, Damian Surr wrote:
>>> ...
>>> /var/lib/mythtv//nfslockfile.lock: Permission denied
>>> Unable to open lockfile!
>>> Be sure that '/var/lib/mythtv/' exists and that both
>>> the directory and that file are writeable by this user.
>> Does the directory exist? This is where MythTV is going to try and
>> store your TV recordings.
> Yes, it's there. I tried running
> sudo mythbackend
> and that error didn't show its self. Must be a permissions thing,  
> but I
> don't know much about that.

`ls -ld /var/lib/mythtv/` will show the permissions for that  
directory, `ls -l /var/lib/mythtv/` will show the permissions for the  
files in that directory.

I've reviewed the first 6 results of <http://www.google.com/search? 
q=linux+file+permissions> and they all look to me equally quite useful.

You would be advised to use the command-line to make some directories  
within your homedir (`mkdir foo`) and change the permissions on those  
directories; what is the effect of changing the group that a  
directory belongs to? What happens to the permissions when you make a  
new file or folder within that directory? What happens when you  
change the group permissions for a directory & then create a new file  
within in? (use `ls -l` to compare `chmod 777 foo/ & touch foo/bar`  
with `chmod 700 grunt/ & touch grunt/wibble`)

I haven't yet installed MythTV, and don't use Ubuntu, so I'm not  
familiar with either Ubuntu's default permissions or how MythTV is  
actually started. I think you said in a previous posting that the  
MythTV setup program worked for one user but not for another. This is  
expected behaviour, and you shouldn't be logging on as user `dave` to  
run `mythbackend`, but it should be started automatically at bootime.


More information about the mythtv-users mailing list