[mythtv-users] atrpms update breaks fedora 8 add/remove

Lan Barnes lan at falleagle.net
Mon Dec 31 02:36:58 UTC 2007

On Sun, December 30, 2007 4:45 pm, Greg Lake wrote:
> Axel Thimm wrote:
>> On Sun, Dec 30, 2007 at 06:02:32PM -0500, Eugene Regad wrote:
>>> Just a word from/to the adventurous and unwise.
>>> On Dec 27, I installed mythtv using the Fedora-7 instructions on the
>>> mythtv site using the
>>> atrpms-package-config-118-1.fc8.i386.rpm.   This was on a bare-metal
>>> installation of Fedora 8
>>> (fully updated).   After I installed mythtv, I got a prompt for an
>>> update of these files (the current installations on F8):
>>> directfb-1.0.0-3.fc8
>>> flac-1.2.1-1.fc8
>>> fuse-2.7.0-8.fc8
>>> ipw2200-firmware-3.0.9
>>> libraw1394-1.3.0-3.fc8
>>> lirc-0.8.2-2.fc8
>>> lm_sensors-2.10.5-1.fc8
>>> lzo-2.02-3.fc8
>>> mutt-1.5.17-2.fc8
>>> pm-utils-0.99.4-6.fc8
>>> After I updated, the Fedora 8 add/remove program was broken.  A bug
>>> report was created,
>>> indicating pirut was malfunctioning.   I didn't send it, since it
>>> didn't
>>> seem reasonable.
>> Why? Any bug report is helpful.
>>> After a bare-metal re-installation and update of Fedora 8, I
>>> re-installed mythtv and got exactly the same result (Again!).  On the
>>> third bare metal install, I removed the atrpms repo entry from
>>> yum.repos.d.   The 'Update prompt ' promptly went away.  I have not
>>> investigated further; mythtv is working well enough for now.
>> This sounds more like a bug in pirut than in atrpms. Perhaps it can't
>> cope with too many packages or too many package dependencies?
>> At any rate when pirut/kyum mess up one should always try to fall back
>> to using plain yum to see whether the bug is in the GUI wrapper. Not
>> that yum is infallible, but at least it narrows down the possibilities.
>> ------------------------------------------------------------------------
>> _______________________________________________
>> mythtv-users mailing list
>> mythtv-users at mythtv.org
>> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
> I had the same problem. In my case, it turned out to be the yum plugin
> fastest mirror that was causing the problem...I removed it and all was
> better.. Did you have that plugin installed?

I am interested in this. When I run this w/F8:

  yum -y install \*myth\*

I run healthy for a while and then error out on too many dependencies. I
have no idea what my yum plug in situation is, or how to diagnose and
modify it.

Lan Barnes

SCM Analyst              Linux Guy
Tcl/Tk Enthusiast        Biodiesel Brewer

More information about the mythtv-users mailing list