[mythtv-users] mpeg decoder for mythcommflag

Chris Pinkham cpinkham at bc2va.org
Wed Dec 12 02:22:53 UTC 2007

* On Mon Dec 10, 2007 at 11:12:44PM -0500, Ken Mandelberg wrote:
> > On 12/10/2007 08:55 AM, Ken Mandelberg wrote:
> >> There is a choice of decoder for playback, Can a choice be made for 
> >> mythcommflag?

Not right now.  I didn't think it would use libmpeg2, but can't recall
right now why it doesn't.  I haven't looked through enough of the code
to determine where the mod would have to be made.

> I submitted a ticket on the mythcommflag problem 3 months ago
> http://svn.mythtv.org/trac/ticket/3925

The commercial flagger only skips frames during the logo detection if you
are using the original flagger.  I'm not sure what the experimental flagger
does.  The 'classic' detector (ie, when you use anything other than
experimental) jumps around during the initial logo detection, but then
seeks back to the beginning and then plays through the file frame by

The reason for using mythtranscode to rebuild the index on mpeg2 files is
that the seektables are built different ways.  There is an open ticket
assigned to me to convert to using MARK_GOP_BYFRAME which shoud fix the
issue and let mythcommflag generate correct seektables instead of having
to use mythtranscode's mpeg2 seektable rebuilder.

> Basically the seek table is off because it doesn't advance the offset on 
> decode errors of the form
> AFD: Opened codec 0x8da0310, id(MPEG2VIDEO) type(Video)

That doesn't look like an error message.


More information about the mythtv-users mailing list