[mythtv-users] mythtv on mips: mythuitest exiting on qApp->exec

jenny tc jennytharayil at gmail.com
Sun Dec 9 08:00:51 UTC 2007

  I am porting mythtv to a mips board.I needed only the mythfrontend on the
board.So I disabled mythbackend by modifying the configure script (set
backend=no).Then I executed the configure script
./configure --arch=MIPS --disable-joystick-menu --disable-firewire
--disable-dbox2 --disable-hdhomerun --disable-xv  --prefi

I used qt-x11-free-3.3.8 and  mysql-4.1.14
  Configured qt with
    ./configure -platform linux-mipsel-linux-gcc -no-xinerama -thread
-qt-sql-mysql -R/home/jenny_tc/project/xwindow/x11r7.3
and i did a native compilation for mysql-4.1.14
   Compilation was successfull and I installed mythtv on the board
   when I executed "mythuitest "  ,I got the error  "mythuitest: Fatal IO
error: client killed" and mythuitest and xserver get aborted.
I tried to debugg this and I came to know that it's exiting when it executes
the "qApp->exec();" statement. What could be the problem?
I am getting the same error when I run mythfrontend also

The log prints  are attached below

  2007-12-09 13:23:11.087 Using runtime prefix = /usr/local
2007-12-09 13:23:11.283 DPMS is disabled.
2007-12-09 13:23:11.431 New DB connection, total: 1
2007-12-09 13:23:11.474 Connected to database 'mythconverg' at host:
2007-12-09 13:23:11.479 Total desktop dim: 1280x720, with 1 screen[s].
2007-12-09 13:23:12.141 Using screen 0, 1280x720 at 0,0
2007-12-09 13:23:14.540 Total desktop dim: 1280x720, with 1 screen[s].
2007-12-09 13:23:15.198 Using screen 0, 1280x720 at 0,0
2007-12-09 13:23:15.204 Switching to square mode (G.A.N.T.)
2007-12-09 13:23:15.526 Using the Qt painter
2007-12-09 13:23:34.953 Loading from:
2007-12-09 13:23:36.103 Loading from:
mythuitest: Fatal IO error: client killed

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20071209/1a69fe10/attachment.htm 

More information about the mythtv-users mailing list