[mythtv-users] Won't Save Backend Settings

David Rush david at rushtone.com
Fri Aug 31 01:24:34 UTC 2007

> Michael T. Dean wrote:
>> On 08/30/2007 11:52 AM, David Rush wrote:
>>> I've been going rounds with my MythTV box, trying to get it all 
>>> working correctly all at once.
>>> I've done a fresh install of Ubuntu 7.04 Feisty Fawn, then selected 
>>> the "mythtv" package and mythtv-plugins via Synaptic.
>>> I've learned that I have to add cx88_dvb to my /etc/modules in order 
>>> to get it to find my pcHDTV HD-3000 tuner card.
>>> However, when I run mythtv-setup, none of the settings I choose get 
>>> saved.  In General setup, the only thing I change is the TV format 
>>> from NTSC to ATSC.  But when I go back into General, TV format is 
>>> back to NTSC.  Same thing trying to set my tuner card or anything else.
>> You are going through all the settings pages in the section (using Next)
>> until you get to the last page, then clicking Finish (= save settings),
>> right?
> Correct.  I go through all the pages and select Finish on the last one.
> David
More info.... /var/log/mythtv/mythbackend.log has some interesting stuff:

2007-08-30 21:14:49.490 Using runtime prefix = /usr
2007-08-30 21:14:49.537 New DB connection, total: 1
2007-08-30 21:14:49.542 Connected to database 'mythconverg' at host: 
2007-08-30 21:14:49.545 Current Schema Version:
2007-08-30 21:14:49.546 Newest Schema Version : 1160
2007-08-30 21:14:49.548 New DB connection, total: 2
2007-08-30 21:14:49.549 Connected to database 'mythconverg' at host: 
2007-08-30 21:14:49.550 Setting Lock for Database Schema upgrade. If you 
see a l
ong pause here it means the Schema is already locked and is being 
upgraded by an
other Myth process.
2007-08-30 21:14:49.552 New DB connection, total: 3
2007-08-30 21:14:49.553 Connected to database 'mythconverg' at host: 
2007-08-30 21:14:49.555 Told to create a NEW database schema, but the 
already has 5 tables.
If you are sure this is a good mythtv database, verify
that the settings table has the DBSchemaVer variable.

2007-08-30 21:14:49.556 Database Schema upgrade FAILED, unlocking.
2007-08-30 21:14:49.557 Couldn't upgrade database to new schema

So, there IS a database problem.  I tried marking mythtv-database for 
reinstallation (and did Apply).  That didn't seem to make any 
difference.  Then I marked it for removal, which also marked "mythtv" 
for removal, did Apply, then marked them for installation again, and hit 
Apply.  Still no difference - got the errors above.  Can anybody 
diagnose this further with the above info?


More information about the mythtv-users mailing list