[mythtv-users] Channel icons

Michael T. Dean mtdean at thirdcontact.com
Wed Aug 29 18:05:58 UTC 2007

On 08/29/2007 08:26 AM, Matt Mossholder wrote:
> On Wed, 2007-08-29 at 05:39 -0400, Michael T. Dean wrote:
>> And how exactly are you trying to get the icons?  As described at
>> http://www.mythtv.org/docs/mythtv-HOWTO-9.html#ss9.5 ?  If so, which
>> method?  Using "perl mkiconmap.pl" or using the "mythfilldatabase
>> --import-icon-map" approach?
> I'm not actually "trying" to download them. It is just occurring as a
> consequence of running mfd, without any prompting on my part.
>> If you're talking about error messages you get during a normal
>> mythfilldatabase run, please try updating your icons as described in the
>> HOWTO (link above) and see if you still get the errors after.
> I'll give it a shot and report back...

Actually, here's a better approach...

Can you please download
and then run:

mythfilldatabase --import-icon-map master_iconmap.xml --reset-icon-map

(that's all one line--just in case it's broken apart by the e-mail) and
then see if you still get the error.

Also, the icons specified in the new iconmap are /much/ better quality
than the old ones, so you may actually want to "reset" your channel
icons to ensure you download new ones.  If so, just add " all" (no
quotes) to the end of the mfdb command above.

When reporting back, please specify whether you ran the "perl
mkiconmap.pl" command before resetting your iconmap (doing so would
likely "fix" the symptom before the problem is fixed).  And, if you did
use mkiconmap.pl, please let me know whether you reset channel icons
with "all" (doing so would clear out the entries that mkiconmap.pl would
have put in place, so would "unfix" the symptom, making it a good test,


More information about the mythtv-users mailing list