[mythtv-users] mythfrontend playback problems after rebuild

James Pifer jep at obrien-pifer.com
Wed Aug 29 14:25:34 UTC 2007

> I rebooted this morning and now sound is working but lirc is hosed. I
> had to mess with lirc yesterday to get it working, somehow I think
> that's what messed up the sound. 
> I'm getting this error with lirc:
> lircd-0.8.3-CVS[3469]: could not open /dev/lirc
> I'm trying to do things that have worked for other people, but it's not
> working for me. I've tried modifying /etc/udev/rules.d/lirc.rules by
> commenting the first line or changing the second line to:
> KERNEL=="lirc0", NAME="%k", SYMLINK="lirc"
> Neither have worked. Right now the file is back to the original:
> KERNEL=="lirc[0-9]*", NAME="lirc%n", MODE="0660", GROUP="lirc"
> KERNEL=="lirc0", SYMLINK="lirc"
> I have this in my modprobe.conf:
> alias char-major-61 lirc_i2c
> install lirc_i2c /sbin/modprobe ivtv; /sbin/modprobe --ignore-install lirc_i2c
> I did modprobe lirc_i2c and restarted lirc and still do not
> have /dev/lirc.
> I'm going to keep trying things, but does anyone know why the symlink is
> not getting created for /dev/lirc?

Alright, found a fix, but don't really understand why I need to do it
this way...

I added this change to /etc/init.d/lirc:
LIRCD_OPTIONS="-d /dev/lirc0 -p 0666"

Then I added this to /etc/rc.local:
/sbin/modprobe lirc_i2c
service lircd start

This seems to work, even after a reboot.


More information about the mythtv-users mailing list