[mythtv-users] 0.20.2 and older versions

Henry A Harper III hah at alumni.rice.edu
Sat Aug 25 12:59:32 UTC 2007

> How does the 0.20.2 frontend work with an older backend? And if it is
> not working, how troublesome is it to update? Is this seamless?

All frontends and backends on a network (that are intended to communicate
with each other) should be the same version, anything else is as they say
"not a supported configuration". A 0.20.2 (or any "newer") frontend will
actually automatically upgrade the database schema on first run, so the
older backend may get confused, not-good things may (will?) happen. The
mythtv protocol versions may be different so you would get an error message
to that effect and they wouldn't talk to one another at all.

The database schema upgrade part is seamless :)

It should be no more troublesome to update the backend than to update a
separate frontend. Certainly ought to be less trouble than building a
separate frontend from scratch.

The 0.20.2 versioning is simply a "tag" for a release that knows about the
new US Schedules Direct grabber, it's not like it is completely different
from previous mythtv versions, it's a snapshot of the continuously evolving
codebase - there are other added features/fixes compared to the 0.20.1
version, of couse.

More information about the mythtv-users mailing list