[mythtv-users] OT? Myth and VNC

George Mari george_mythusers at mari1938.org
Fri Aug 24 15:50:58 UTC 2007

Jay Mallar wrote:
> Has anyone been able to get Myth running over VNC?  In particular, I'm 
> using Fedora Core 7, and the stable version of Mythtv.  I'm also using 
> the Xvnc that comes with Fedora. 
> Trying to run mythtv-setup gives me Xlib errors that XInputExtension is 
> missing.  I've tried adding +extension XInputExtenion but it doesn't 
> seem to have any effect.  Further, according to the RealVNC website, my 
> verison of XVnc comes with XInputExtension enabled by default anyway.
> What's the trick?
> Xvnc Free Edition 4.1.2
> Copyright (C) 2002-2005 RealVNC Ltd.
> See http://www.realvnc.com for information on VNC.
> Underlying X server release 10300000, The X.Org Foundation
> $ rpm -qi vnc-server
> Name        : vnc-server                   Relocations: (not relocatable)
> Version     : 4.1.2                             Vendor: Fedora Project
> Release     : 18.fc7                        Build Date: Mon 11 Jun 2007 
> 08:53:02 AM CDT
> Install Date: Sun 19 Aug 2007 02:34:53 PM CDT      Build Host: 
> xenbuilder2.fedora.redhat.com
> Group       : User Interface/X              Source RPM: 
> vnc-4.1.2-18.fc7.src.rpm
> Size        : 4556831                          License: GPL
> Signature   : DSA/SHA1, Mon 11 Jun 2007 01:58:30 PM CDT, Key ID 
> b44269d04f2a6fd2
> Packager    : Fedora Project
> URL         : http://www.realvnc.com
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

Have you tried loading the vnc module in your xorg.conf?  I'm running 
FC6, and I have following in xorg.conf:

Section "Module"
         Load  "dbe"
         Load  "extmod"
         Load  "fbdevhw"
         Load  "glx"
         Load  "record"
         Load  "freetype"
         Load  "type1"
         Load  "vnc"
         Load  "v4l"

I have the vnc-server rpm also installed, but I don't actually run it:

[root at poseidon X11]# chkconfig --list | grep vnc
vncserver       0:off   1:off   2:off   3:off   4:off   5:off   6:off
[root at poseidon X11]# service vncserver status
Xvnc is stopped
[root at poseidon X11]#

It works fine for me - no problems accessing the remote desktop this way 
at all.  Of course, playing back video, you don't actually see the 
video, just the first frame or so, or just a black screen.

More information about the mythtv-users mailing list