[mythtv-users] mythtv-setup and X forward

Kevin Kuphal kuphal at dls.net
Fri Aug 24 14:48:08 UTC 2007

On 8/24/07, Joacim J <jocke4news at gmail.com> wrote:
> Hello,
> A bit of stupid question...
> I have a klient and a server both running Kubuntu Feisty.
> I have now compiled MythTV on the server for running mythbackend but now I
> need to run mythtv-setup.
> I have tried running it over VNC but get:
> ======================================
> root at frodo:/home/joacim# /usr/local/mythtv_svn_r14230/bin/mythtv-setup
> Xlib: connection to ":1.0" refused by server
> Xlib: No protocol specified
> mythtv-setup: cannot connect to X server : 1.0
> ======================================
> How can I run this?
> Is it possible/better to start mythtv-setup from a regular SSH session and
> in that case how?
> PS. I would prefer to solve VNC since I need it for other purposes but
> it's most important to get it running :) DS
> Have a nice weekend!

Ignoring the question of why you don't just run this on the console of the
backend with a monitor and keyboard during setup, from the client, run

ssh -X server

and you should be good to go
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20070824/1591d8ab/attachment.htm 

More information about the mythtv-users mailing list