[mythtv-users] Program not found in PAT!

James Cummings cummings.james at gmail.com
Fri Aug 24 12:38:43 UTC 2007

On 8/24/07, Neil Bothwick <neil at stfw.net> wrote:
> On Fri, 24 Aug 2007 10:50:19 +0100, Mike Perkins wrote:
> > > Since Monday, my mythbackend.log has been filling up with lines like
> > >
> > > 2007-08-20 15:53:25.362 Program #8301 not found in PAT!
> > >
> > > The program number is always the same and they can appear at the rate
> > > of several per second, then none for a few minute, with well over a
> > > million in the last four days. I haven't touched my backend setup
> > > since at least a week before this started. I am using
> > > mythtv-0.20.1_p14146 on Gentoo.
> > I'll second that. Tried to record the two Bourne films shown recently
> > on ITV2? and got 42 Mb of log entries containing nothing but the above.
> > Backend stayed up; continued doing the basic jobs while the above went
> > on; finished (it thought) the recordings, no problems with any other
> > recordings done before or since. Got two 0Mb files out of it. I wonder,
> > since it only affected two similar films, whether they might have had
> > some strange formatting in the stream to cause this. Whatever, I
> > suspect these were kernel messages, not myth messages.
> Totally different symptoms here. Recording work OK, but the backend keeps
> stopping (to be restarted by Monit). These are MythTV messages as far as
> I can determine.

Re: programme not in PAT

These messages started for me when the channel 4 line-up changed in the UK.
For those of you in the UK, I'm guessing the culprit is the change to the
new channel 4 lineup which did this:

Channel 4:  was 4 remains 4
Channel 4+1 :  new number 13
More 4 :  was 13 - new number 14
E4:  was 14 - new number 29
E4+1: remains 30
Film 4: was 29 - new number 32
Film 4+1: was 32 - no longer available

I tried full rescan of channels (since I get data via EIT), but although
that got me the new channel lineup, it hasn't stopped these messages.  I'm
thinking maybe I had something scheduled for Film4+1 which no longer
exists?  Would that cause this?  If so, how would I get rid of it?  I don't
want to wipe all my scheduling/priorities as it has taken me awhile to get
them right.


A full error message is:

2007-08-24 08:47:45.983 Program #8296 not found in PAT!
Program Association Table
 PSIP tableID(0x0) length(69) extension(0x2007)
      version(2) current(1) section(0) last_section(0)
         tsid: 8199
 programCount: 15
  program number 0 has PID 0x  10   data  0x0 0x0 0x224 0x16
  program number 8263 has PID 0x 100   data  0x32 0x71 0x225 0x0
  program number 8358 has PID 0x 107   data  0x32 0x166 0x225 0x7
  program number 8573 has PID 0x 110   data  0x33 0x125 0x225 0x16
  program number 8642 has PID 0x 112   data  0x33 0x194 0x225 0x18
  program number 8384 has PID 0x 108   data  0x32 0x192 0x225 0x8
  program number 8768 has PID 0x 114   data  0x34 0x64 0x225 0x20
  program number 8452 has PID 0x 10c   data  0x33 0x4 0x225 0x12
  program number 8448 has PID 0x 10b   data  0x33 0x0 0x225 0x11
  program number 8442 has PID 0x 10e   data  0x32 0x250 0x225 0x14
  program number 8353 has PID 0x 116   data  0x32 0x161 0x225 0x22
  program number 8771 has PID 0x 11a   data  0x34 0x67 0x225 0x26
  program number 8772 has PID 0x 11c   data  0x34 0x68 0x225 0x28
  program number 8325 has PID 0x 102   data  0x32 0x133 0x225 0x2
  program number 8294 has PID 0x 104   data  0x32 0x102 0x225 0x4


James Cummings, Cummings dot James at GMail dot com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mythtv.org/pipermail/mythtv-users/attachments/20070824/27ed12f5/attachment.htm 

More information about the mythtv-users mailing list