[mythtv-users] Storage groups to solve I/O wait

Taco Mel taco_mel at yahoo.com
Tue Aug 21 04:29:49 UTC 2007

> Have you chase-played an HD recording successfully
before?  Or was this 
> the first time, and you saw this hesitation?

This was the first time on an essentially brand new
setup, since I have only had a HD-capable front end
for a couple days now.

> My suggestion would be, while you are
"chase-playing" an HD recording, 
> and recording something else on the PVR500, open a
console window and 
> run iostat -xd 2, and look at your numbers under the
columns "svctm" and 
> "%util".  (Note: iostat was not part of my standard
FC6 install, I had 
> to download it separately, I think from the extras
repository; check to 
> see if it's included in your distro.)

I grabbed the "sysstat" package which contains this
tool.  Just for fun I kicked it off (right now one SD
recording and one commercial flag jobs are going) and
got about 50% utilization with around 2.2 MB/s read
and 1.2 MB/s write (iostat -xdm 2).  Just for fun I
started up a "dd if=/dev/zero of=/storage/foo bs=1024
count=500000" and got 100% utilization with 0.2 MB/s
read and 4.9 MB/s write.  (In contrast, to an IDE
drive I stuck in, I got 32 MB/s write at 100%

So, I will be approaching this as an issue with the
3ware settings, rather than something that takes a
complicated MythTV workaround.  Thanks for that tip.

Be a better Globetrotter. Get better travel answers from someone who knows. Yahoo! Answers - Check it out.

More information about the mythtv-users mailing list