[mythtv-users] Can't get usb iMon VFD working on Silverstone LC16M case

Bob maillists.mythtv at gmail.com
Fri Aug 10 23:10:10 UTC 2007

On Friday 10 August 2007 22:45, Nick Morrott wrote:
> On 10/08/07, Bob <maillists.mythtv at gmail.com> wrote:
> > I think that the hardware might be broken.  As I understand it plugging
> > in _any_ USB device will give you some output in the system log and be
> > shown if you do a lsusb.
> The best place to look for answers is http://venky.ws/projects/imon/ but...
> > If I remove a working device, eg my mouse, I get a 'device disconnected'
> > message in the logs but when I plug the VFD in I get absolutely no output
> > in the log.  If I reconnect the mouse I get a 'device connected' log
> > message.
> I've never hot-swapped my VFD. Power down the machine, plug it in, and
> restart it.
> lsusb should show a device with a vendor:product ID of 15c2:ffdc -
> this is the VFD. I see no  mention of the manufacturer in the output
> or anything else to readily identify it, this information was garnered
> from previous investigation.
> > Does this mean the hardware is broken?  Or is it possible that it's just
> > not being recognised.
> I'd be worried if it didn't show up in lsusb _at all_. Have you got
> the relevant driver installed (standalone or LIRC-enabled)? I don't
> remember seeing any output in the syslogs on boot, but then the box is
> never rebooted...

Yeah, I originally I was trying with it plugged in at boot time, if I boot 
with just the VFD plugged in (to a known good port):

# lsusb
Bus 001 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000

I _think_ I've got the right drivers, lirc-0.8.1 and lcdproc-0.5.1, but 
# modprobe lirc_dev lirc_imon
# lsusb
Bus 001 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000

Like I say, even without drivers, _something_ should come up in lsusb/logs 
shouldn't it?

If I plug the 'knob and buttons' usb device in before booting:
# lsusb
Bus 001 Device 001: ID 0000:0000
Bus 002 Device 002: ID 0b38:0003
Bus 002 Device 001: ID 0000:0000

but it's a totally separate device I gather.


More information about the mythtv-users mailing list