[mythtv-users] nuvexport - Xvid and MP4 not working (even though compiled in ffmpeg)

Matt skd5aner at gmail.com
Thu Aug 9 18:51:51 UTC 2007

On 8/9/07, Brad DerManouelian <myth at dermanouelian.com> wrote:
> On Aug 9, 2007, at 10:50 AM, Matt wrote:
> > Hi,
> >
> > I'm having an issue where xvid is disabled saying that ffmpeg hasn't
> > been compiled with it, however... I just compiled it from source and I
> > know it was.  I'm using current ffmpeg SVN from today.
> >
> > In addition, MP4 (ipod) says it's disabled because it doesn't support
> > encoding to AAC, but FAAD and FAAC are both compiled in.
> >
> > I'm running ubuntu, but compiled nuvexport and ffmpeg from SVN
> > source today.
> Are you running into this?
> http://www.gossamer-threads.com/lists/mythtv/dev/282791
> http://www.gossamer-threads.com/lists/mythtv/dev/282597
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users

Yup... that's it.  I replaced it and it now is no longer disabled.
However, I still have an issue when trying to run an MP4 (h264)

Choose a function, or episode(s) to remove:  c
Where would you like to export the files to? [.]
Enable Myth cutlist? [Yes]
Enable noise reduction (slower, but better results)? [No]
Enable deinterlacing? [Yes]
Crop broadcast overscan border (0-5%) ? [1.5]
Audio bitrate? [64] 128
Enable iPod compatibility? [Yes] no
Video codec (mpeg4 or h264)? [h264]
Variable bitrate video? [Yes]
Multi-pass (slower, but better quality)? [Yes]
Video bitrate? [384]
Default resolution based on requested dimensions.
Width? [320] 480
Height? [368]

Now encoding:  Saturday Night Live:  Untitled
Encode started:  Thu Aug  9 14:49:08 2007
First pass...
Waiting for mythtranscode to set up the fifos.
Starting ffmpeg.
processed:  0 of -138631 frames at 0 fps (~%, eta: unknown)

ffmpeg had critical errors:

Unknown codec 'h264'

I'm guessing that somewhere else it's passing the wrong codec name to
ffmpeg.  I haven't really had a chance to dive in yet and fix this as
I really don't have a lot of perl or ffmpeg knowledge to know what
should be passed.

Either way, I guess someone should open a ticket so Chris can fix this.


More information about the mythtv-users mailing list