[mythtv-users] ivtv/lirc kdmls for F7 (was: GANT theme ...)

Axel Thimm Axel.Thimm at ATrpms.net
Mon Aug 6 11:16:08 UTC 2007

On Sun, Aug 05, 2007 at 09:02:56PM -0400, andrew allison wrote:
> My probems were related to installng the software dependencies
> kernel 2.6.21 has no ivtv-kmdl rpm package avaliable
> apparently the rpm for 2.6.21 ivtv-kmdl has been deleted.

ivtv would not build on F7 until Hans pushed out 1.0.1 which was after
F7 jumped on 2.6.22. And while 1.0.1 builds on F7's 2.6.22 it doesn't
on 2.6.21-1.3194.fc7. And all the other kernels in between have been
withdrawn upstream (e.g. the kernel rpms deleted on the Fedora
mirrors), so offering support for them makes no sense.

>  I had to download the source and compile
> (Just make sure you get the right version)

You probably built against 2.6.22 headers, if you build against the
proper headers you will end with:

  CC [M]  /builddir/ivtv-1.0.1/driver/ivtv-fb.o
In file included from /builddir/ivtv-1.0.1/driver/ivtv-fb.c:59:
error: media/ivtv.h: No such file or directory

But the module will still work also on 2.6.21, so there is no big harm

> kernel 2.6.22 has no working lirc package avaliable
> apparently they have changed a buffer size and the PVR-150 hangs your machine

You mean the current lirc 0.8.2 kmdls hang? Is there a patch for that?
Axel.Thimm at ATrpms.net
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://mythtv.org/pipermail/mythtv-users/attachments/20070806/2aff40ae/attachment.pgp 

More information about the mythtv-users mailing list