[mythtv-users] Lirc Problem with 2.6.22 Kernel

Greg Ahpee greg at ahpee.org
Sat Aug 4 04:20:35 UTC 2007

Ma Begaj wrote:
> There is a patch on the lirc mailing list. Here is a copy:
> ------------------------------------------------------------------------
> diff -ur lirc-0.8.2/drivers/lirc_i2c/lirc_i2c.c
> lirc-0.8.2.new/drivers/lirc_i2c/lirc_i2c.c
> --- lirc-0.8.2/drivers/lirc_i2c/lirc_i2c.c	2007-02-13 00:45:15.000000000 -0600
> +++ lirc-0.8.2.new/drivers/lirc_i2c/lirc_i2c.c	2007-07-23
> 09:47:51.582717400 -0500
> @@ -420,7 +420,7 @@
>  		   Hauppauge cards, but the data flow is different, so we need
>  		   to deal with it by its own.
>  		 */
> -		strcpy(ir->c.name,"Hauppauge IR (PVR150)");
> +		strcpy(ir->c.name,"Hauppauge PVR150");
>  		ir->l.code_length = 13;
>  		ir->l.add_to_buf=add_to_buf_haup_pvr150;
>  		break;
> ------------------------------------------------------------------------
> M.
> 2007/7/25, Tom Dexter <digitalaudiorock at hotmail.com>:
>>> From: Greg Ahpee
>>> After upgrading my kernel from 2.6.21 to 2.6.22 I am experiencing a
>>> problem with the transmit function in lirc. Testing indicates that the
>>> software carrier frequency being generated by lirc is now double what it
>>> should be as I was able to get a partial response by setting the
>>> frequency to 20kHz instead of the default 38kHz which was working before
>>> the kernel upgrade. Can anyone offer any advice?
>>> Greg
>> Thought you might be interested in this from the Gentoo forum regarding some
>> lirc issues with 2.6.22.  You're issue might be related:
>> http://forums.gentoo.org/viewtopic-t-571712.html
>> Tom
>> _________________________________________________________________
>> Local listings, incredible imagery, and driving directions - all in one
>> place! http://maps.live.com/?wip=69&FORM=MGAC01
>> _______________________________________________
>> mythtv-users mailing list
>> mythtv-users at mythtv.org
>> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
Thanks to all who have tried to help. The problem has finally been 
solved by following an off-list suggestion from auric which I have 
pasted below for the benefit of anyone else in the same situation:

Greg, Have the same problem. Have found by forcing rdtsc mode fixes the
problem for me.

In lirc 0.8.2 src change drivers/lirc_serial/lirc_serial.c lines
#if defined(rdtsc)

#define USE_RDTSC
#warning "Note: using rdtsc instruction"

/*#if defined(rdtsc)*/

#define USE_RDTSC
#warning "Note: using rdtsc instruction"

i.e comment out the if defined and so force rdtsc mode.
(The actual bug appears to be caused by changes in the kernel headers,
but this will get around it).

Note/ You need a pentium 3 or later to use rdtsc mode.


ps, If you are like me and are using a RPM package for lirc, I just
replaced the kernel driver and left everything else as the rpm.
download lirc source
setup.sh and choose serial, homebrew, software carrier, transmit.
edit src as above
then just copy the drivers/lirc_serial/lirc_serial.ko over the rpm
installed one

you need to have the kernel-devel package to make, can get this via yum

More information about the mythtv-users mailing list