[mythtv-users] mythfilldatabase fails on every query

William Munson william_munson at bellsouth.net
Thu Apr 26 15:57:37 UTC 2007

Jeffrey Bush wrote:
> Hi,
> I just installed MythTV and I have just finished importing mc.sql into my
> mysql database and running mythtv-setup. Like I should, I than ran
> mythfilldatabase, which ends up failing no every query. It cannot create the
> tables and it cannot insert (obviously) because the tables don't exist (and
> that is the error it gives).
> I have MySQL 5.0.21. Is this not a good version to use? The mysql server is
> definitely running. And the mythfilldatabase is definitely connecting to it
> because it knows the tables don't exist. The main problem is the fact it
> cannot create the tables themselves.
> Checking in mysql, looking at the users table, the mythtv user has a
> password, is this correct? (My root user had a password when I imported
> mc.sql).
> How do I get mythfilldatabase working?

Not an expert here. It appears that mythtv-setup is accessing the 
database so your password and user are correct. Assuming you are in the 
usa then perhaps there is something wrong with your zap2it account. 
Maybe its expired, maybe they are just having problems right now. Log 
into your account to make sure its active and that your lineup is still 
there.  If that is correct then delete your sources and recreate them. 
When you run the "fetch channels from provider" button, does it populate 
the channels for that source? If you forget to push that button, 
mythfilldatabase will fail.

More information about the mythtv-users mailing list