[mythtv-users] External channel change not passing channel

Kevin Plew kevin at plewnet.com
Sun Apr 1 18:26:05 UTC 2007

Michael T. Dean wrote:
> On 04/01/2007 04:25 AM, duck wrote:
>> David Watkins wrote:
>>> On 01/04/07, duck <tduckett at tdux.com> wrote:
>>>> For some reason Myth is not passing the channel number to the external
>>>> channel changer script.  I have removed all cards from my server except
>>>> the pvr-150 and tried several tests and cannot get the external channel
>>>> change to work.  If I run the directv.pl script by hand it functions
>>>> properly!  I am using the latest mythtv version .0.20 and I even tried
>>>> using an older version and it still did not work.  No errors in any of
>>>> the log files.  Thank you!!!
>>> you could edit your channel change script to echo the parameter into
>>> an file.  Then you would find out:
>>> a)  whether myth was actually calling the script.
>>> b)  what parameter (if any) myth is passing to it.
>> I wrote a simple shell script:
>> channel_changer
>> echo $1 $2 $3 $4 $5 $6 $7 $8  $9 > test
>> /capture/directv.pl box_type RCA_OLD setup_channel $1
>> output in test
>> /channel/changer
>> The channel number is never being passed.
> Chances are your command is not properly configured.  (PATH problem?)  
> So, without your providing info on how you've configured it, it's hard 
> for us to tell you how to fix the configuration...  ;)
> Mike
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
I had problems with the "box_type" option.

This what I have:

External Change Command "/usr/bin/change_channel /dev/ttyUSB0"

/usr/bin/change_channel looks like this

if [ "X$1" = "X" ] || [ "X$2" = "X" ]; then
       echo "Usage: $0 <port> <channel number>"
/usr/local/bin/directv.pl port $1 setup_channel $2 hide

I used the latest version of directv.pl from this website: http://www.pdp8.net/directv/directv.shtml

Most of this came from the wiki but I played with baudrate and box_type which don't work. Make sure everything is executable by mythtv.

More information about the mythtv-users mailing list