[mythtv-users] Audio Buffer Underruns with XvMC and HD in 0.20

Ben Curtis mythtv at nosolutions.com
Sat Sep 30 20:35:44 UTC 2006

> Also put me down in the camp of those for whom XvMC has stopped
> working properly and started spewing audio overruns after upgrading to
> 0.20 (ATrpms, in my case). I normally didn't use XvMC much before 0.20
> because of the "audio overruns when displaying the OSD or channel
> text" issue, but otherwise the video and audio were 100%. 0.20 has
> resolved the inconsistency, in a fashion: Now the video and audio
> *always* stutter as if the OSD is being displayed, and the actual OSD
> itself doesn't make a difference!

Sign me up, too.  .19 has worked flawlessly forever, now .20 I can't watch
any HD.  My issues are stuttering, with or without deinterlacing, and Bob
even makes the screen bounce up and down.  As of .20, I also have a few
new errors cropping up from mythfrontend:

2006-09-30 15:34:27.655 VideoOutputXv: XvMCTex: Init failed
2006-09-30 15:34:27.655 VideoOutputXv: XvMC Adaptor Name: 'NV17 Video
2006-09-30 15:34:28.996 Realtime priority would require SUID as root.
2006-09-30 15:34:29.007 TV: Changing from None to WatchingPreRecorded
2006-09-30 15:34:29.200 Video timing method: USleep with busy wait
2006-09-30 15:34:29.258 VideoOutputXv Error: ProcessFrameXvMC: Failed to
get OSD lock
2006-09-30 15:34:29.260 VideoOutputXv Error: ProcessFrameXvMC: Failed to
get OSD lock

I never saw any of the VideoOutputXv lines (4 of them) in .19.  I've tried
everything in the Wiki, etc no luck.

If this can't be solved, is it possible for me to downgrade a single
frontend to .19 (the one I watch HD on) and keep the others at .20?  And
if so, anyone know how?  I upgraded with yum.


More information about the mythtv-users mailing list