[mythtv-users] Can't access my Mp3 collection

Andrew Davis andrew at nccomp.com
Wed Sep 27 03:51:40 UTC 2006

That is exactly the message I get... the whole:

"metadata.o: You don't seem to have any tracks. That's ok with me if
it's ok with you."

Though it also appears to be scanning the CD/DVD drive for tracks to 
play. I'm running .20 though, not .19. You noted this was an issue with 
0.19... was there a workaround or patch?

I'll double-check paths and permissions tomorrow. I thought I was doing 
everything right, but also thought I might be missing something obvious.

Dewey Smolka wrote:
>> I just copied my entire MP3 collection into /data/mp3s on my Myth box.
>> There's a folder hierarchy of artist->album->song.
>> I've updated the "Directory to hold music" to /data/mp3s and confirmed
>> the mythtv user can fully traverse this path and all sub-dirs at a
>> shell. However, I don't seem to be able to add the songs to a playlist,
>> etc. If I go into Music Tools->Scan for new music, it flashes for a
>> second, then just returns to the same screen.
> Hmmm. You seem to be doing everything you should be doing.
> If the scan fails to find anything, it should give you a message like:
> "metadata.o: You don't seem to have any tracks. That's ok with me if
> it's ok with you." (this is on 0.19 -- don't know if it's changed in
> .20)
> First, double check that you haven't incorrectly entered your music
> directory in the setup -- eg data/mp3 or /data/Mp3.
> Second, just for kicks, run:
> #chown -R mythtv /data/mp3  -- (assuming mythtv is your mythtv user)
> and scan again.

More information about the mythtv-users mailing list