[mythtv-users] quick question: mythbackend startup script on SBE

Iohan Reyes ijr at routex.net
Tue Sep 26 18:56:46 UTC 2006


I am running mythtv 0.20 on FC5.  When I use the "/sbin/service
mythbackend start" command, mythbackend fails to start on my Slave
Backend server with the following error:

2006-09-26 14:41:41.961 Using runtime prefix = /usr
2006-09-26 14:41:42.068 New DB connection, total: 1
2006-09-26 14:41:42.100 Unable to connect to database!
2006-09-26 14:41:42.100 Driver error was [1/2002]:
QMYSQL3: Unable to connect
Database error was:
Can't connect to local MySQL server through socket
'/var/lib/mysql/mysql.sock' (2)

QSqlQuery::exec: database not open
QSqlQuery::exec: database not open
2006-09-26 14:41:42.161 DB Error (KickDatabase):
Query was:
No error type from QSqlError?  Strange...
2006-09-26 14:41:42.213 Failed to init MythContext, exiting.

If I run it manually by using the actual "mythbackend" binary, it starts

[root at parallax init.d]# mythbackend
2006-09-26 14:44:23.598 Using runtime prefix = /usr
2006-09-26 14:44:23.668 New DB connection, total: 1
2006-09-26 14:44:23.717 Connected to database 'mythconverg' at host:
2006-09-26 14:44:23.724 Current Schema Version: 1160
Running as a slave backend.
2006-09-26 14:44:23.769 New DB connection, total: 2
2006-09-26 14:44:23.778 Connected to database 'mythconverg' at host:
2006-09-26 14:44:23.781 EITHelper: localtime offset -4:00:00
2006-09-26 14:44:23.790 New DB connection, total: 3
2006-09-26 14:44:23.794 Connected to database 'mythconverg' at host:
2006-09-26 14:44:23.907 Main::Starting HttpServer
2006-09-26 14:44:23.916 Main::Registering HttpStatus Extension
2006-09-26 14:44:23.918 mythbackend version: 0.20.20060828-3
2006-09-26 14:44:23.919 Enabled verbose msgs:  important general
2006-09-26 14:44:23.920 AutoExpire: Found 1 recorders w/max rate of 72
2006-09-26 14:44:23.922 AutoExpire: Required Free Space: 2.1 GB w/freq:
10 min
2006-09-26 14:44:24.929 Connecting to master server:
2006-09-26 14:44:24.930 Connected successfully
2006-09-26 14:44:25.196 TVRec(1): Changing from None to RecordingOnly
2006-09-26 14:44:25.199 TVRec(1): HW Tuner: 1->1

Apparently the startup script is not aware that it is on an SBE and
doesn't know that it needs to connect to for its database, so
it fails when it tries to connect to a non-running mysql socket on

Can you tell me where I can specify or what file to edit to make it work
properly?  I thought it was the ~/.mythtv/mysql.txt file or the
/root/.mythtv/mysql.txt, but I checked that both are configured properly
and the startup script still doesn't work.

Any help will be greatly appreciated. Thanks!

More information about the mythtv-users mailing list