[mythtv-users] Hauppauge PVR500 MCE Remote Doesn't Work

Andrew Davis andrew at nccomp.com
Tue Sep 26 17:41:41 UTC 2006

Thanks for the clarification. It helped greatly. My linux experience had 
me thinking there was a difference between a conf file and an rc file, 
but I guess I got confused... presumably from the lack for clarification 
in the guide I followed. Nonetheless, your reply got me working... at 
least somewhat... Turns out I mistakenly assumed I had a Hauppauge 
remote since I bought it bundled with my PVR500 card. Who knew they'd 
bundle someone else remote? :) FWIW, I read the man-page for irrecord, 
then consulted http://lirc.sourceforge.net/remotes/ and found only the 
RC-5 seemed to match, though mine was an RC-6. I tried both configs in 
the RC-5 folder, neither worked. Thus I simply ran irrecord and followed 
the prompts. It detected I had an RC-6 then let me setup my key names 
and now "irw" actually does something. :)



Joel Means wrote:
> Hash: SHA1
>>  0 lrwxrwxrwx  1 mythtv mythtv    15 Sep 26 09:25 lircrc -> /etc/lircd.conf
>>  0 lrwxrwxrwx  1 mythtv mythtv    15 Sep 26 09:25 .lircrc -> /etc/lircd.conf
>> And in /home/mythtv, I have:
>> 0 lrwxrwxrwx  1 mythtv mythtv   15 Sep 26 09:26 .lircrc -> /etc/lircd.conf
> The /etc/lircd.conf and .lircrc files are different.  lircd.conf tells
> lirc what a certain code is (relates the received code to a certain
> button on a certain remote).  The lircrc file tells a program (such as
> mythtv or xine) what to do when the lirc daemon recognizes a signal that
> it receives (that is, when it finds it in the lircd.conf file).  Look at
> this page: http://wilsonet.com/mythtv/remotes.php and under "2.
> Software" you will find an example lircd.conf and an example .lircrc
> file for a radio shack remote.  Looking at these should give you an idea
> of the difference between the two files.
>> Basically, I have a single config file in /etc that the mythtv user can 
>> read and symlinks in other places pointing at it.
>> Unfortunately, running irw still gives nothing... even after reboots and 
>> such...
> Another problem is that the remote you have is not the Hauppauge remote.
>  Hauppauge doesn't sell the 500 with a remote (as far as I know).  You
> bought yours bundled with a Microsoft MCE remote (at least that is what
> it looks like to my untrained eye in the pictures you linked in the
> original post).  Try finding a configuration file for the MCE remote and
> see if that helps.  You may have to create your own using irrecord.  Try
> using the mode2 command (as root) to see if the receiver is picking up
> anything at all.  What irw does is tell you what button you pushed if it
> is found in your lircd.conf file.
> Hope this helps.
> Joel
> Version: GnuPG v1.4.3 (GNU/Linux)
> Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org
> iD8DBQFFGVoy0tbb2uIZyCURAiw7AJ4/HU/UENygSmqxYxUbkF/A19OLmQCZAdwZ
> 7YGh3vDuNWnfHMvCddoYxWE=
> =QgAD

More information about the mythtv-users mailing list