[mythtv-users] lirc not working/crashing

Andrew Davis andrew at nccomp.com
Tue Sep 26 16:13:12 UTC 2006

Nick wrote:
> On 26/09/06, Andrew Davis <andrew at nccomp.com> wrote:
>> I got that too after changing the perms of /dev/lircd. In my case, udev
>> (on FC5) was hanging on startup with my USB IR receiver plugged in after
>> adjusting the perms for /dev/lircd. A quick check (ls -als /dev/lirc*)
>> showed that only /dev/lircd existed and /dev/lirc did not. I created a
>> symlink and pointed /dev/lirc at /dev/lircd and the the issues while
>> running irw went away (ln -s /dev/lircd /dev/lirc).
>> Of course, per my other post to the list... while this particular issue
>> is resolved (and didn't even occur til I changed the perm's of
>> /dev/lircd to get my remote working), my remote still doesn't work...
> What's the output of lsmod |grep "lirc" ?
> Does irw work?
> Nick
> MythTV Official wiki:
> http://mythtv.org/wiki/
> MythTV users list archive:
> http://www.gossamer-threads.com/lists/mythtv/users
Here's the output:

[root at emperor dvds]# lsmod|grep lirc
lirc_mceusb2           13444  0
lirc_dev               16932  1 lirc_mceusb2

And the output of dmesg immediately after plugging in the receiver:

usb 3-1: new full speed USB device using uhci_hcd and address 2
usb 3-1: configuration #1 chosen from 1 choice
lirc_dev: IR Remote Control driver registered, at major 61
lirc_mceusb2: USB remote driver for LIRC v0.22
lirc_mceusb2: Martin Blatter <martin_a_blatter at yahoo.com>
usb 3-1: reset full speed USB device using uhci_hcd and address 2
lirc_dev: lirc_register_plugin: sample_rate: 0
lirc_mceusb2[2]: SMK eHome Infrared Transceiver on usb3:2
usbcore: registered new driver lirc_mceusb2

And, no, irw still doesn't work...

More information about the mythtv-users mailing list