[mythtv-users] mythtv on 2.6.18 + ivtv not possible?

Janne Grunau janne-mythtvusers at grunau.be
Tue Sep 26 10:47:21 UTC 2006

On Tuesday 26 September 2006 12:12, Timo Boettcher wrote:
> Hi!
>   since there is ivtv-0.8.0 for 2.6.18, I tried to upgrade.
>   Today, I read on the ivtv-mailinglist that mythtv won't work
>   on 2.6.18 with ivtv.

Read again. That's not true and Hans Verkuil didn't wrote it either. 
MythTV 0.20 from tarballs should work flawlessly with 2.6.18 and ivtv 
0.8 on x86 32 bit. For 64bit you would need revision 11274 or later of 
the release-0.20 branch. A uncatched change in the kernel headers had 
made MythTV incompatible with the kernel.

>   Quoting http://bugs.gentoo.org/show_bug.cgi?id=149039#c5
>   I will happily bump ivtv to 0.8 and enjoy as all the MythTV
>   users yell and scream since MythTV has had an open bug about
>   V4L2 support for 3 months and they're shipping version doesn't
>   support it. What does this mean?

I don't know and can't make anything out of it. The ticket for V4L2 MPEG 
encoding API was committed and closed after one week and is not much 
older than 2 months.
Regular V4L2 (against V4L) support is alson not an issue since V4L 
compatibility is in 2.6.18. 

>   MythTV will not work with 2.6.18 and higher kernels.


>   Has anyone here tried that configuration and got results?

It's working fine.


More information about the mythtv-users mailing list