[mythtv-users] Hauppauge PVR500 MCE Remote Doesn't Work

Andrew Davis andrew at nccomp.com
Mon Sep 25 21:54:18 UTC 2006

I just spent the weekend getting a MythTV box up and running (actually, 
I spent about 4 hours getting it working and the rest of the weekend 
learning to follow instructions before assuming I know what I'm doing). 
Following the advice of some, I chose to minimize my complexities, so 
I'm still connected to my 17'' LCD, not my wide screen TV and my cable 
feed is simply splitting the input rather than connecting the output of 
my tuner box to the input of my card. So far, all seems to be working 
fine, except for two issues... the first of which I'm posting to the list.

My hardware includes the Hauppauge PVR-500 MCE w/ Remote (I bought the 
bundle that includes the remote and receiver after reading at various 
places that it works). Unfortunately, I think I have a newer one and it 
doesn't work. Mine meets the "grey and black" description, but it 
completely lacks "four colored buttons" as the ones that are working 
seem to have. In a nutshell, I plugged in the receiver to the USB port 
and dmesg showed it. I went through all the lirc installation steps, but 
when I open up irw (either as the mythtv user or root) and press buttons 
on the remote, I get nothing.... nothing at all. I've tried forcing it 
to work with different module options (lirc_i2c, lirc_mceusb, 
lirc_mceusb2). The (current) relevant portions of my /etc/modprobe.conf 

alias char-major-61 lirc_mceusb2
install lirc_mceusb2 /sbin/modprobe ivtv; /sbin/modprobe 
--ignore-install lirc_mceusb2

Please note these are the current settings... with the device alias at 
the top of the file and the install line at the bottom. I've also tried 
lirc_i2c and lirc_mceusb and always get absolutely nothing from irw. 
Ironically, all the howto's and such just tell you how to get it 
working, then say to start lircd and irw and you should see output as 
you push buttons... even lirc's webpage says this, but none mention what 
to do when you don't get any output...

My BIOS lacks a physical COM2 port, but offers an option to enable it 
and has various IR options. I've disabled this in the BIOS, but I've 
seen Linux find h/w that disabled in the BIOS before, so perhaps this is 

I did a lot of research on this and am getting quote frustrated. I'm 
running FC5 and followed the guide here: 
http://wilsonet.com/mythtv/fcmyth.php. The good news is I can navigate 
with my keyboard. I tried every option mentioned in the HOWTO above... 
tried for an older grey only remote, older grey/black, and newer 
grey/black. I also found this page: 
http://www.mythtv.org/wiki/index.php/MCE_Remote and realized I have 
neither of these... hence my assumption that I have a newer remote. Note 
that the receiver seems to be detected by linux just fine (at least 
according to dmesg) and the modules load without warning. Also to note, 
when I press a button on the remote, I see a red light flash on the USB 
receiver, so I'm pretty sure the remote is chatting properly with the 
receiver. The receiver includes what I believe is a remote extender 
(mono, headphone style connection on one end, black thingy at the other. 
The receiver has ports 1 and 2 presumably for one or more of these. I've 
tried the setup with and without the *extender*. For the sake of 
clarity, I've posted pictures of the remote and receiver:


As you can see, my remote lacks the four "colored buttons" that all the 
remote howto articles describe.

The sticker inside the battery compartment says:
G MX 6 29 C

Here's some dmesg output depending on the various modules I try:

(with lirc_mceusb2)
usb 3-1: new full speed USB device using uhci_hcd and address 2
usb 3-1: configuration #1 chosen from 1 choice
lirc_dev: IR Remote Control driver registered, at major 61

lirc_mceusb2: USB remote driver for LIRC v0.22
lirc_mceusb2: Martin Blatter <martin_a_blatter at yahoo.com>
usb 3-1: reset full speed USB device using uhci_hcd and address 2
lirc_dev: lirc_register_plugin: sample_rate: 0
lirc_mceusb2[2]: SMK eHome Infrared Transceiver on usb3:2
usbcore: registered new driver lirc_mceusb2

(with lirc_mceusb)
lirc_mceusb2[2]: usb remote disconnected
usb 3-1: new full speed USB device using uhci_hcd and address 3
usb 3-1: configuration #1 chosen from 1 choice
usb 3-1: reset full speed USB device using uhci_hcd and address 3
lirc_dev: lirc_register_plugin: sample_rate: 0
lirc_mceusb2[3]: SMK eHome Infrared Transceiver on usb3:3

(with lirc_i2c)
usb 3-1: new full speed USB device using uhci_hcd and address 4
usb 3-1: configuration #1 chosen from 1 choice
usb 3-1: reset full speed USB device using uhci_hcd and address 4
lirc_dev: lirc_register_plugin: sample_rate: 0
lirc_mceusb2[4]: SMK eHome Infrared Transceiver on usb3:4

Note that no matter what I say in /etc/modprobe.conf, dmesg always shows 
it as using lirc_mceusb2... which tells me this is the correct 
module/driver... but I can't figure out why this thing won't work...

So, anyone have this working? Any suggestions?

More information about the mythtv-users mailing list