[mythtv-users] Mytharchive DVD fails to play

Aaron Segaert segaera at mcmaster.ca
Sun Sep 24 14:22:13 UTC 2006

I tried to burn a DVD using mytharchive, upon inserting the disc the 
menu works, but the movies fail to play, crashing the DVD player after a 
few seconds.

I'm using MythTV 0.20 and Ubuntu 6.06.

Checking in Mytharchive's working directory, the video files themselves 
are ok.  The problem is with burning the DVD.  Looking at mythburn.log, 
everything is okay until the end.  Here is the part with the error message:

Burning ISO image to /dev/dvd
Executing 'mkisofs -dvd-video -V MythTV BurnDVD /opt/mythtv/tmp/work/dvd 
| builtin_dd of=/dev/dvd obs=32k seek=0'
INFO:   UTF-8 character encoding detected by locale settings.
        Assuming UTF-8 encoded filenames on source filesystem,
        use -input-charset to override.
/dev/dvd: "Current Write Speed" is 1.0x1385KBps.
  0.28% done, estimate finish Sun Sep 24 04:36:29 2006
  0.55% done, estimate finish Sun Sep 24 03:51:37 2006
  0.83% done, estimate finish Sun Sep 24 03:36:34 2006
  1.11% done, estimate finish Sun Sep 24 03:29:05 2006
  1.39% done, estimate finish Sun Sep 24 03:25:46 2006
:-[ WRITE at LBA=62c0h failed with SK=5h/ASC=21h/ACQ=02h]: Invalid argument
:-( write failed: Invalid argument
/dev/dvd: flushing cache
/dev/dvd: updating RMA
/dev/dvd: closing disc
/dev/dvd: reloading tray
mkisofs: Broken pipe. cannot fwrite 32768*1
Finished burning ISO image
Finished processing jobs!!!

These error messages are cryptic to me. Does anyone know what this means 
and how I can fix it?

More information about the mythtv-users mailing list