[mythtv-users] Myth 0.20 problems on Gentoo

Robin Smith 1canuck2 at gmail.com
Sat Sep 23 00:07:44 UTC 2006

> > Basically, my backend crashes with a seg fault after a seemingly
> > random period of time.
> I had a similar problem, I fixed it by adding the ivtv option to my USE
> statement and recompiling mythtv.  It started working fine after that.

Sweet! I'll give that a try right now. I do so hope to get my
stability back but keep the new features of Myth 0.20. My wife's gonna
kill me if we lose anymore scheduled recordings...

Okay, I don't see a ivtv use flag being used by Myht, so I am not sure
what difference this will make. Do you mean you added ivtv to
/etc/make.conf, or to /etc/portage/package.use? I have tried both and
when I do the emerge -v mythtv, it doesn't show ivtv as a compile
option its going to use. Am I doing this wrong?

>> After watching a recording, I delete it. It goes away as if deleted,
>> then comes back. I have seen this before (pre 0.19) when the file
>> wasn't actually there (say a bad recording), but in this case the file
>> is definitely there as I am able to watch it again. If I play the
>> show, edit it and set some cut points, transcode it, wait until
>> transcoding is done, then delete, it works!
>Can you give me step by step screen clicks on how to replicate this?
>If you're directions are detailed I'll give it a try and let you know
>if I see the same.

There's not much to recreating the problem. Basically, I watch a
recording, when it ends I have MythTV set to prompt, I select Delete
Recording from the prompt and it does what it usually does and removes
the show, after a couple of seconds, pop!, the show re-appears (and
can be rewatched, so the file isn't being deleted). This is from the
Watch Recordings screen.

The only way I could make it delete was to basically create a cutlist,
transcode the show and then when I tried to delete the show it work (I
do lossless tranacode).

More information about the mythtv-users mailing list