[mythtv-users] OSX build problem

David Snider dsnider at thesniderpad.com
Fri Sep 22 19:31:25 UTC 2006

On Sep 21, 2006, at 5:26 AM, Simon Grasser wrote:

> i tired to build mythtv on a mac os x panther server machine with  
> the following:
> freetype-2.1.10.tar.gz
> lame-3.96.1.tar.gz
> libdvdcss-1.2.9.tar.bz2
> libdvdread-0.9.4.tar.gz
> mysql-4.0.26.tar.gz
> qt-mac-free-3.3.4.tar.gz
> and the perl packaging tool from the mythtv site http:// 
> steadydecline.net/public/osx-packager.pl

To be honest, I would probably use the official osx-packager.pl from  
SVN @ http://svn.mythtv.org/trac/browser/trunk/mythtv/contrib/osx- 
packager.pl.  It is regularly updated and compiles and fetches all  
the dependencies for you fairly well.

> during the compile of qt-mac-free-3.3.4.tar.gz it stops with an  
> error. does anyone have a pointer to this? would I need to compiele  
> against that same version of mysql that is installed on the mac os  
> x server? or even the same version that is installed on the backend  
> (4.1)?:
You shouldn't have to have the exact same mysql client as the server,  
in other applications I can use a 4.x client to access a 3.x database  
without issue.

More information about the mythtv-users mailing list