[mythtv-users] Firewire Problems, was working

Jim Westfall jwestfall at surrealistic.net
Thu Sep 21 20:33:05 EDT 2006

Allan Wilson <allanwilson at gmail.com> wrote [09.21.06]:
> Ok I gave it a shot and didn't have much luck. I applied the patch to the
> latest code from svn and that part worked find. I then ran mythtv-setup and
> set up the extra cable box using p2p and sa3250. I then started the backend
> then the frontend and below is what I got:

could you give me the output from plugreport when both are plugged in.

> mythfrontend
> 2006-09-21 18:28:09.051 TV: Attempting to change from None to WatchingLiveTV
> 2006-09-21 18:28:09.052 Using protocol version 30
> 2006-09-21 18:28:15.985 RingBuf(/video/tv/2773_20060921182809.mpg): Invalid
> file  (fd -1) when opening '/video/tv/2773_20060921182809.mpg'.
> 2006-09-21 18:28:16.016 NVP::OpenFile(): Error, file not found:
> /video/tv/2773_2 0060921182809.mpg
> 2006-09-21 18:28:16.018 TV Error: StartPlayer(): NVP is not playing after
> 20000 msec
> 2006-09-21 18:28:23.021 MythSocket(847db28:22): readStringList: Error,
> timeout ( quick).
> 2006-09-21 18:28:23.021 RemoteEncoder::SendReceiveStringList(): No response.
> 2006-09-21 18:28:23.026 TV Error: LiveTV not successfully started
> mythbackend
> 2006-09-21 18:28:09.055 TVRec(7): Changing from None to WatchingLiveTV
> 2006-09-21 18:28:09.056 TVRec(7): HW Tuner: 7->7
> 2006-09-21 18:28:09.495 FireRec: Buffered packets 2000 (8000 KB)
> 2006-09-21 18:28:16.022 TVRec(7): Changing from WatchingLiveTV to None
> 2006-09-21 18:28:24.505 FireRec: No Input in 15 seconds [P:0 N:1] (select)
> 2006-09-21 18:28:24.523 Finished recording SportsCenter: channel 2773
> 2006-09-21 18:28:24.530 MythSocket(8305140:-1): writeStringList: Error,
> socket went unconnected.

next time please run the backend with '-v channel,playback' and send the 
output from the channel change to the No Input line.  Dont worry about 
sending frontend logs.

> When I went to watching live tv I just got a black screen. I also took out
> the external channel changer command because I noticed that the channel was
> changing to something in the 873 instead of 783. Once I took the channel
> changer command out it just stopped changing channels. Then I changed it to
> the sa4250 cable box and channel changing started working properly. As a
> last resort I tried broadcast and I had no luck but that could have been
> because of my plugctl commands. The entire time everything worked good using
> test-mpeg2. The girlfriend ran me off to watch some of her shows but I
> should be able to start testing again in a couple of hours if you want me to
> try anything new.

what plugctl commands are you running? 

could you run the firewire_tester on both SA3250s too.


More information about the mythtv-users mailing list