[mythtv-users] PATH, QTDIR, and qmake

scott at tbwifi.ca scott at tbwifi.ca
Tue Sep 19 15:04:29 UTC 2006

> On Tue Sep 19, 2006 at 08:07:36AM -0600, scott at tbwifi.ca wrote:
>> Hi Rich,
>> As you see at the top of this post, I was albe to set the QTDIR
>> properly,
>> but when I type
>> $ which qmake
>> it doesn't list the published directory.  I get
>> /usr/bin/qmake
>> instead of
>> /usr/lib/qt3/bin/qmake
> The setting of QTDIR is absolutely irrelevant when using 'which', as
> this purely looks at the PATH variable.  If you wish to use
> /usr/lib/qt3/bin/qmake instead of /usr/bin/qmake, then you have to make
> sure that /usr/lib/qt3/bin appears ahead of /usr/bin in the PATH, e.g.
> for bash, try "export PATH=/usr/lib/qt3/bin:${PATH}".
> QTDIR becomes relevant (or should do) when using configure or other
> automated programs, which ought to look there for QT executables,
> libraries, etc. before trying the standard locations (PATH,
> HTH,
>         Robin
> --
>      ___
>     ( ' }     |       Robin Hill        <myth at robinhill.me.uk> |
>    / / )      | Little Jim says ....                            |
>   // !!       |      "He fallen in de water !!"                 |
> _______________________________________________
> mythtv-users mailing list
> mythtv-users at mythtv.org
> http://mythtv.org/cgi-bin/mailman/listinfo/mythtv-users
Thx Robin,
Maybe you can shed some light on my situation.  I originally missed the
step to set the PATH and QTDIR.  I ran qmake, make, and make install and a
great deal seemed to happen...newbee :^).  However, when I tried to setup
the database and or run mythtv-setup things didn't appear to be complete. 
I caught the step I missed in the doc, and have since fixed them and
started the qmake process again.  Is this possibly what was wrong with the
first try?

More information about the mythtv-users mailing list