[mythtv-users] Cutting commercials after transcoding

Dewey Smolka dsmolka at gmail.com
Sat Sep 16 03:24:59 UTC 2006

Sorry to reply to my own post, but I've done a bit more digging (and
need to apologize for not adequately googling).

I found an answer at http://mythtv-fr.info/wiki/wiki.php?doc-off about
halfway down the page:

The transcoding profile used for manual transcoding is whatever was
set when the recording was originally configured, even if you didn't
enable auto-transcoding. The only way to change what transcoding
profile will be used is to alter the transcoder column in the recorded
table in the database. The transcoder column contains a number which
corresponds with the id column in the recordingprofiles table. You can
find out the id number for each profile in the transcoder group with
an SQL command like:

   mysql> select r.* from recordingprofiles r,profilegroups p where
p.name='Transcoders' and p.id=r.profilegroup;
   | id | name           | videocodec | audiocodec | profilegroup |
   | 21 | RTjpeg/MPEG4   | MPEG-4     | MP3        |            6 |
   | 22 | MPEG2          | MPEG-4     | MP3        |            6 |
   | 27 | High Quality   | MPEG-4     | MP3        |            6 |
   | 28 | Medium Quality | MPEG-4     | MP3        |            6 |
   | 29 | Low Quality    | MPEG-4     | MP3        |            6 |
   5 rows in set (0.01 sec)

So I ran the mythtranscode command with -p 21 and got exactly the same
output file size as with -p autodetect (a ha!)

When I tried it with -p 28, the output file size went down to 265 MB.

But when I ran it with -p 27, I got the unknown codec error. Why would that be?

To make things stranger, when I ran -p 22 (which I didn't expect to
work since the source was already transcoded) I got the same output
size as with -p 28.

Why would High Quality fail from an unknown codec? Why would MPEG-2
work when the source was already MPEG-4? Why would it give me the
exact same as Medium Quality?

Also, all of these still have interlacing artefacts when viewed in
mplayer, including the source nuv. Is there any mythtranscode argument
to apply deinterlacing? I'd rather deal with this in the transcoding
process rather than the mplayer command.

Again, thanks for any insight.

More information about the mythtv-users mailing list