[mythtv-users] Reverting from qt 4.1.4 to 3.3.6-r1 for SVN compile

Robin Hill myth at robinhill.me.uk
Wed Sep 13 19:48:09 UTC 2006

On Wed Sep 13, 2006 at 02:08:58PM -0500, Secret Name wrote:

> Hi,
> I would like to compile SVN but my qt is 4.1.4.  I have 3.3.6-r1 also
> installed but cannot figure out if I can use it.  I am using gentoo 2006.1:
> Is there anyway to change the compiler to use the older version for the myth
> compile?  With gcc you just gcc-config (profile number) to change.  I am
> wondering if qt can do this too?
What I've done is created a couple of aliases:
        alias qt3configure="PATH=/usr/qt3/bin:$PATH ./configure"
        alias qt3make="PATH=/usr/qt/3/bin:\$PATH make"

Then I can just call qt3configure and qt3make - it'll use the qmake
executable from /usr/qt3/bin instead of /usr/bin (which is the QT4
version), so pulls in the correct includes & libraries.


    ( ' }     |       Robin Hill        <myth at robinhill.me.uk> |
   / / )      | Little Jim says ....                            |
  // !!       |      "He fallen in de water !!"                 |
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
Url : http://mythtv.org/pipermail/mythtv-users/attachments/20060913/1f9d14c4/attachment.pgp 

More information about the mythtv-users mailing list