[mythtv-users] Documenting my screwup...

Axel Thimm Axel.Thimm at ATrpms.net
Wed Sep 13 17:43:30 UTC 2006

On Wed, Sep 13, 2006 at 10:16:05AM -0600, CHRIS KOTTING wrote:
> Just checking to see if I've figured this out correctly (I don't have the 
> ability to check or fix this right now...), and maybe document the fix for 
> other folks.
> I used apt to upgrade a combined front/backend from 0.19 to 0.20 using 
> Axel's repo.  [Thank You, Axel!]  (BTW: I know about smart and yum, but 
> right now apt is what's on the box.)  I now get the following error from 
> mythweb:

apt is fine.

> Error at /var/www/html/mythweb/includes/mythbackend.php, line 167:
> Incompatible protocol version (mythweb=30, backend=26)
> <followed by other related issues>
> I think in last night's fuzzy-headedness I ran "apt-get upgrade mythtv" 
> instad of "apt-get upgrade mythtv-suite", so I'm still running 0.19 for a 
> few pieces.

Neither is correct, you need

apt-get dist-upgrade

> Am I (probably) correct in my thought that this is the problem?

Upgrade the system as above and restart the backend.
Axel.Thimm at ATrpms.net
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://mythtv.org/pipermail/mythtv-users/attachments/20060913/dbf1693a/attachment.pgp 

More information about the mythtv-users mailing list