[mythtv-users] lirc downgrade trouble (was: Re: Mythtv 0.20 - PVR-350 video out... gone?)

Brian May brian at bmay.org
Wed Sep 13 16:03:24 UTC 2006

>> On 9/12/06, Brian May <brian at bmay.org> wrote:
>>> Did that as well.. rolled back to the latest stable versions of lirc,
>>> kernel, kernel-modules..  changed grub to use the old kernel..
>>> basically
>>> did everything that worked in the past.. but isn't working now.
>> Now to the stupid stuff: did you unplug and plug back in the receiver?
>>  What happens when you try irw?  Have you tried unloading and
>> reloading the modules?
>> Very wierd that it would screw up like this, but I have done upgrades,
>> and also moved my box and inadvertantly unplugged the receiver only to
>> think it was a software issue, when really, it was a hardware issue.
> Checked the hardware, rebooted, no luck.  I will try different "things" I
> get home.

Ok.. no luck after last night's tinkering..

usually if I reinstall the previous version, everything seems to work out
just fine.. but this time no such luck..

is lirc dependant on a ivtv version?  here's what I have installed for both:

:~> uname -a
Linux lies 2.6.12-1.1381_FC3 #1 Fri Oct 21 03:46:49 EDT 2005 i586 i586
i386 GNU/Linux

:~> rpm -qa | grep lirc

:~> rpm -qa | grep ivtv

[root at lies ~]# cat /var/log/dmesg | grep lirc
lirc_dev: IR Remote Control driver registered, at major 61
lirc_i2c: chip found @ 0x18 (Hauppauge IR)
lirc_dev: lirc_register_plugin: sample_rate: 10

[root at lies ~]# ls /dev/lirc* -l
crw-rw-rw-  1 root root 61, 0 Sep 13 00:05 /dev/lirc0
srw-rw-rw-  1 root root     0 Sep 13 08:49 /dev/lircd

[root at lies ~]# irexec
[root at lies ~]# tail /var/log/messages
Sep 13 08:49:25 lies lircd-0.8.0[5837]: lircd(userspace) ready
Sep 13 08:49:25 lies lircd: lircd startup succeeded
Sep 13 08:50:11 lies lircd-0.8.0[5837]: accepted new client on /dev/lircd
Sep 13 08:50:11 lies lircd-0.8.0[5837]: could not get file information for
Sep 13 08:50:11 lies lircd-0.8.0[5837]: default_init(): No such file or
Sep 13 08:50:11 lies lircd-0.8.0[5837]: caught signal

[root at lies ~]# cat /etc/modprobe.conf
alias snd-card-0 snd-emu10k1
alias usb-controller1 uhci-hcd
# ivtv modules setup
alias char-major-81 ivtv
alias char-major-81-0 ivtv
alias char-major-61 lirc_i2c

install lirc_i2c /sbin/modprobe ivtv; /sbin/modprobe --ignore-install

[root at lies ~]# modprobe -l | grep lirc

More information about the mythtv-users mailing list